i got an error too.. on SDK version 3.0.1