×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2006
    Posts
    16

    problem with capabilities

    I am trying to use CTelephony::GetCurrentNetworkInfo to get network info
    (allthough i have a developer certificate signed with ReadDeviceData but without ACS key), i get a message "required application access not granted".
    i sign the app with location networkservices readdevicedata readuserdata writedevicedata writeuserdata and i still dont have the right access.
    when i try on-device debug carbide asks me to sign the app with the proper certificate.

    i have tried everything i could think of and nothing worked .any suggestions?

  2. #2
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: problem with capabilities

    Make sure you have a UID from the correct range.

    Did you go through the process of creating a symbian signed account, entering your IMEI phone number, generating a csr and then downling the certificat file?

    You cannot use a self generated file (generated by MakeKeys) for Read/Write device data.

  3. #3
    Registered User
    Join Date
    Jul 2006
    Posts
    16

    Re: problem with capabilities

    thanx for the answer..
    problem solved. the csr file wasnt writen properly but symbiansigned gave me a certificate. i created a new certificate and everything works perfectly

Similar Threads

  1. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  2. SIP capabilities problem
    By ademar123 in forum Symbian
    Replies: 0
    Last Post: 2005-05-11, 15:32
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×