×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    13

    Exclamation Question about the SIPExample

    Hi all,

    i'm trying to use the SIPExample that came with the SDK 3.0 (C:\Symbian\9.1\S60_3rd\S60Ex\SIPExample)

    Now the question is:

    When i sent a IM(instant message) to another client who is also running the same SIPExample
    and registered on the same sip server, the foreign client indeed receive my IM.

    p.s: IM is sent with the SIP method: MESSAGE

    Yet i thought there should be a set of response like 1XX, 150, or 200 sending to me
    when the IM was reached to the recipient, i.e, my AP should be notified at MSIPConnectionObserver::IncomingResponse().

    However, the function, IncomingResponse() seemed never to be invoked...
    I've read the document comes with the SIPExample (C:\Symbian\9.1\S60_3rd\S60Ex\SIPExample\doc\index.html).
    The document also says that i'll be notified by IncomingResponse()....( in this image )

    So...please tell me where goes wrong??
    or i've misunderstand something?

    Thanks in advance,

    John

  2. #2
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    66

    Re: Question about the SIPExample

    Hi,
    For me its working fine, i am getting the 200 ok Response after sending Message method.I think the problem is with server, so what server you are using???. I tried with server emulator which came with SDK, its working fine for me.
    and How you are testing the example?? means with 3 PCs or what???
    Just check epocwind.out

    Thanks &Regards
    satya

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    13

    Re: Question about the SIPExample

    hi satya,
    thanks for the reply..
    i've solved the problem.
    it's seem that i should use the UDP protocol so that the application can receive the 200 OK response.
    With the TCP, no response will be send back to me after the message have been sent...

    i'm not using the SIP server emulator.
    i'm connecting to true SIP server.

    anyway thanks for ur comment

    best regards,
    John

Similar Threads

  1. a question about command and a question about s60
    By t4kesting in forum Mobile Java General
    Replies: 0
    Last Post: 2006-01-24, 08:21
  2. Replies: 2
    Last Post: 2004-01-08, 18:36
  3. Question on support of dll's
    By sanju_v in forum Symbian
    Replies: 1
    Last Post: 2003-03-05, 13:09
  4. Sending data using iAcceptedSocket (Urgent question)
    By okegame in forum Bluetooth Technology
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×