×

Discussion Board

Results 1 to 4 of 4

Hybrid View

  1. #1
    Registered User
    Join Date
    Feb 2007
    Location
    Bangalore
    Posts
    3

    Question Porting from s60 2nd to 3rd edition

    Hi,

    I am trying to port some code (IP multimedia subsystem) from symbian 8.0 to 9.1. While compiling for 9.0, I am getting one error like "hal.h is not found". I have searched for this file in \Symbian\9.1\Epoc32\include\ folder, but not found. The file is there in 8.0; but not in 9.0.
    As per the nokia document, S60_Platform_Porting_from_2nd_to_3rd_Edition_v1_1_en.pdf, the file is included in the SDK, but some function parameters are changed (for ::Get).

    Any idea?? what to do?? I am totally stucked up here..

    Thanks in advance,
    John

  2. #2
    Registered User
    Join Date
    Mar 2005
    Posts
    37

    Re: Porting from s60 2nd to 3rd edition

    I have it in my 3.0 MR (maintenance release) sdk . Download the latest sdk, it should be in.

  3. #3
    Super Contributor
    Join Date
    Jun 2006
    Location
    Moscow, Russia
    Posts
    803

    Re: Porting from s60 2nd to 3rd edition

    Hi,

    looks like your SDK is really corrupt, I also have hal.h in my S60_3rd SDK.
    Regards,
    ivey

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    27

    Re: Porting from s60 2nd to 3rd edition

    Hi
    I´m not really sure. But when you have install the SDK 3.0 MR you eventual need the extension plugin. http://www.forum.nokia.com/info/sw.n...60_3rd_ed.html

Similar Threads

  1. creating s60 2nd edition application launcher
    By puh_sk8@hotmail.com in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2007-01-09, 08:25
  2. Remote Camera Manager - S60 3rd edition
    By pspickett in forum General Development Questions
    Replies: 0
    Last Post: 2006-12-18, 07:02
  3. RTP stack on S60 3rd edition
    By kit_walker in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2006-09-28, 14:37
  4. TTime : TInt64& Int64() problem in S60 3rd edition
    By iulian_moldovan in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-01-24, 13:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×