×

Discussion Board

Results 1 to 4 of 4

Thread: Unicode

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    8

    Unicode

    Hi,
    I have downloaded the SDK 3.0 Beta and it seem that it does not support Unicode.
    I have Nokia 6210, win98 and Visual Stodio 6.0 SP5.
    I am using "pIShortMessage" object and the "Send" method and as a resualt I get Error number 7935 (Unknown error). Just as SDK2.1.

    Can any one help me , please ..?

    Tnx in advance.

    Tamir

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    379

    RE: Unicode

    Hi,

    Thank you for the feedback, Nokia PC Connectivity SDK 3.0 does support Unicode characters and there should not be any major problems with the beta version of the SDK. However we will look further with this question. Can you provide us information about the used development enviroment, for e.g. connection method, hardware used and possible other software installed.

    Best regards,

    Marko Tuukkanen
    Forum Nokia

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    6

    RE: Unicode

    I got the same problem.I using VC++6.0sp5,Chinese windows2000 sp3 ,when I run the program,
    I can got message in the end mobile,but I can't see "Test" in the Mobile.It is a blank message. Using the sample under SDK3.0 folder got the same problem.I can got normal English Text.But I can't got unicode Text.I using Chinese version NOKIA7110.

    BSTR bstrEndAddr=_com_util::ConvertStringToBSTR(szMobileNo);
    BSTR bstrSCAddr=_com_util::ConvertStringToBSTR(szSmca);
    BSTR bstrDataText=_com_util::ConvertStringToBSTR("Test"

    try
    {
    pSMSEntry->Type=SHORTMESSAGE_TYPE_GSM_SUBMIT;

    pIGSMSubmit->put_Message(bstrDataText);
    pIGSMSubmit->put_DestinationAddress(bstrEndAddr);
    pIGSMSubmit->put_ServiceCenterAddress(bstrSCAddr);
    pIGSMSubmit->put_DataCodingScheme(0x8);
    pIGSMSubmit->ProtocolID= 0;
    pIGSMSubmit->ValidityPeriodRelative = 255;
    }

    catch( _com_error ) {printf("pIGSMSubmit failed "}
    try
    {
    pMessage->SendSMS(SHORTMESSAGE_ROUTE_TYPE_ANY, pIGSMSubmit);
    }
    catch( _com_error ) {printf(" Send Message failed "}

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    8

    RE: Unicode

    Well,
    I solved it.
    I changed the phone model to Nokia 6310i and I am using the "namespace NokiaCLMessaging" - NCLMSG.DLL.

    It works now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×