×

Discussion Board

Results 1 to 15 of 21

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    E65 SIP connection problem

    I'm trying to connect my E65 to the sipgate.de VoIP service using the built-in client, however it seems to be unable to establish a connection. I started investigating the issue a bit myself and while I couldn't pin down the cause of the problem due to lack of access to a tcpdump-style application for S60 to confirm that UDP packages don't get lost anywhere after passing the WLAN-router, I do think that the problem is to be looked for on the device itself.
    I captured packages on the router's WLAN device in order to take a look at the communication between phone and sipgate.de and the results show that a packages sent by the E65 do indeed reach the sipgate server, however the response is either not or incorrectly processed by the SIP implementation on the phone.
    To initiate a connection, a REGISTER request is sent to the server but apparently the response, a "401 Unauthorized", is not processed but instead the REGISTER request is repeated in increasing intervals (3s, 6s, 12s,..). According the the RFC, the device should resend the request with credentials added and CSeq increased, however nothing inside the request gets changed for the next send.
    The response packages are sent to the phone over the WLAN device on the router so I assume the problem doesn't lie here.

    I'm a bit out of ideas of how to fix this issue without debugging access to the SIP application on the E65 but maybe there's something I'm missing and someone here has a solution for the problem.
    Would be great since VoIP was one of the main reasons for me to buy this phone

    Part of the capture:
    Code:
    No.     Time        Source                Destination           Protocol Info
          1 0.000000    84.191.201.140        217.10.79.9           SIP      Request: REGISTER sip:sipgate.de;transport=UDP
    
    Frame 1 (470 bytes on wire, 470 bytes captured)
    Linux cooked capture
    Internet Protocol, Src: 84.191.201.140 (84.191.201.140), Dst: 217.10.79.9 (217.10.79.9)
    User Datagram Protocol, Src Port: 5060 (5060), Dst Port: 5060 (5060)
    Session Initiation Protocol
        Request-Line: REGISTER sip:sipgate.de;transport=UDP SIP/2.0
        Message Header
            Via: SIP/2.0/UDP 84.191.201.140:5060;branch=z9hG4bKetou3ao40lhc6glt0g5ga31;rport
            From: <sip:[removed]@sipgate.de>;tag=4vce3auojphc7aka0g5g
            To: <sip:[removed]@sipgate.de>
            Contact: <sip:[removed]@84.191.201.140:5060;transport=UDP>;expires=3600
            CSeq: 867 REGISTER
            Call-ID: 9LXxGX1PoIcsLwgb1pDkI13Q3z94AA
            User-Agent: Nokia RM-208 1.0633.18.01
            Max-Forwards: 70
            Content-Length: 0
    
    No.     Time        Source                Destination           Protocol Info
          2 0.072174    217.10.79.9           84.191.201.140        SIP      Status: 401 Unauthorized    (0 bindings)
    
    Frame 2 (463 bytes on wire, 463 bytes captured)
    Linux cooked capture
    Internet Protocol, Src: 217.10.79.9 (217.10.79.9), Dst: 84.191.201.140 (84.191.201.140)
    User Datagram Protocol, Src Port: 5060 (5060), Dst Port: 5060 (5060)
    Session Initiation Protocol
        Status-Line: SIP/2.0 401 Unauthorized
        Message Header
            Via: SIP/2.0/UDP 84.191.201.140:5060;branch=z9hG4bKetou3ao40lhc6glt0g5ga31;rport=5060
            From: <sip:[removed]@sipgate.de>;tag=4vce3auojphc7aka0g5g
            To: <sip:[removed]@sipgate.de>;tag=b11cb9bb270104b49a99a995b8c68544.f30e
            CSeq: 867 REGISTER
            Call-ID: 9LXxGX1PoIcsLwgb1pDkI13Q3z94AA
            WWW-Authenticate: Digest realm="sipgate.de", nonce="45e5e7ebf6d3cc7e078e8295ba71a9092ea68bc7"
            Content-Length: 0
    
    No.     Time        Source                Destination           Protocol Info
          3 3.016895    84.191.201.140        217.10.79.9           SIP      Request: REGISTER sip:sipgate.de;transport=UDP
    
    Frame 3 (470 bytes on wire, 470 bytes captured)
    Linux cooked capture
    Internet Protocol, Src: 84.191.201.140 (84.191.201.140), Dst: 217.10.79.9 (217.10.79.9)
    User Datagram Protocol, Src Port: 5060 (5060), Dst Port: 5060 (5060)
    Session Initiation Protocol
        Request-Line: REGISTER sip:sipgate.de;transport=UDP SIP/2.0
        Message Header
            Via: SIP/2.0/UDP 84.191.201.140:5060;branch=z9hG4bKetou3ao40lhc6glt0g5ga31;rport
            From: <sip:[removed]@sipgate.de>;tag=4vce3auojphc7aka0g5g
            To: <sip:[removed]@sipgate.de>
            Contact: <sip:[removed]@84.191.201.140:5060;transport=UDP>;expires=3600
            CSeq: 867 REGISTER
            Call-ID: 9LXxGX1PoIcsLwgb1pDkI13Q3z94AA
            User-Agent: Nokia RM-208 1.0633.18.01
            Max-Forwards: 70
            Content-Length: 0
    
    [...]

  2. #2
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: E65 SIP connection problem

    Update:
    The same behaviour can be seen when trying to connect to internetcalls.com
    While testing this additional VoIP service, I encountered another weird issue:
    when there is more than one SIP profile defined, only the 1st one comes as far as described above, any other profile added at a later point doesn't even send any of the UDP messages but simply returns with "unable to connect to the connection network".

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: E65 SIP connection problem

    Quote Originally Posted by Razzle
    Update:
    The same behaviour can be seen when trying to connect to internetcalls.com
    While testing this additional VoIP service, I encountered another weird issue:
    when there is more than one SIP profile defined, only the 1st one comes as far as described above, any other profile added at a later point doesn't even send any of the UDP messages but simply returns with "unable to connect to the connection network".
    Razzle, I'm facing the same problem. I'm able to do VoIP over EGPRS but as soon as I try and do it over my Netgear WGT624 router I only get "unable to connect to the connection network" the biggest reason for me to buy the phone was to be able to use VoIP over my WiFi connection , now I'm not sure what to do ? Have tried all types of setting with UPnP on my router, Port Forwarding to 5060 abd all combinations of SIP setups but still what I get is "unable to connect to the connection network" !

    In case you come across a solution for this problem, do help out a fellow user. This phone was just launched in 'India and I was probably the 1st few to buy one, my E65's Firmware version is 1.0633.18.01 dated 11/01/07 RM-208; is a new firmware out may be that has addressed this issue ?

    Lets keep posted !

    Adios !

  4. #4
    Registered User
    Join Date
    Mar 2007
    Posts
    3

    Re: E65 SIP connection problem

    My friends Razzle and madusa, i have the E65 and it's great, there is nothing wrong with your phone, i just solve the "unable to connect to the connection network" problem. All you have to do is fill ALL the fields in the profile in the sip setting section, my problem was that i did'nt fill the REGISTRAR SERVER information, but when i use the same server name that the proxy server and fill all the fields info it works, i use it to register to SIPPHONE.COM and it works great.

    I hope this can help you.

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: E65 SIP connection problem

    Quote Originally Posted by Los_Angeles
    My friends Razzle and madusa, i have the E65 and it's great, there is nothing wrong with your phone, i just solve the "unable to connect to the connection network" problem. All you have to do is fill ALL the fields in the profile in the sip setting section, my problem was that i did'nt fill the REGISTRAR SERVER information, but when i use the same server name that the proxy server and fill all the fields info it works, i use it to register to SIPPHONE.COM and it works great.

    I hope this can help you.
    Thanx for th input LA ! I've tried that as well, the only way the router is letting a SIP connection form my phone is by shutting off the SPI firewall (not recommended) on the router, till now thats the only way my phone's SIP connection goes through and connects via my Netgear router. Will upgrade the firmware and c how it goes.

  6. #6
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: E65 SIP connection problem

    My E65 is currently being repaired (faulty display) so I don't really have any big updates but I'm pretty sure I had filled in all details and it still didn't work.
    In fact, I had set up an asterisk server in the local network and tried to make it connect to that to rule out the router firewall as a possible issue but I encountered exactly the same problem there.

    I suspect that it might be the firmware which is branded by my network provider, I will try and see if I can get an unbranded version once I have my phone back.

  7. #7
    Registered User
    Join Date
    Apr 2007
    Posts
    2

    Re: E65 SIP connection problem

    Quote Originally Posted by Los_Angeles
    My friends Razzle and madusa, i have the E65 and it's great, there is nothing wrong with your phone, i just solve the "unable to connect to the connection network" problem. All you have to do is fill ALL the fields in the profile in the sip setting section, my problem was that i did'nt fill the REGISTRAR SERVER information, but when i use the same server name that the proxy server and fill all the fields info it works, i use it to register to SIPPHONE.COM and it works great.

    I hope this can help you.

    Hi LA,

    I got my E65 couple of days ago.. I am trying to connect to Sipphone.com desperately. I have a SPA 3000 connected to Sipphone.com since 3 yrs. But with E65, i am having quite some difficulty.. Could you plz put in here the parameters.. I am finding it difficult with the "REALM". I dont know what to put in here for Proxy settings and Registrar settings.. Any help is greatly appreciated..
    regards,
    Cmreddy

  8. #8
    Registered User
    Join Date
    Mar 2007
    Posts
    3

    Re: E65 SIP connection problem

    Hi Cmreddy, i have a SPA 3102 it's a great device.

    In the E65 in the menu > tools > setting > connection > SIPsetting
    - create a new profile and give it a name (like sipphone)
    -service profile is IETF
    - define the default access point
    - in the public user name write somethink like sip:1747xxxxxx@proxy01.sipphone.com where 1747xxxxxx is your number
    -use compression No
    -Registration: When needed
    - Use security: No

    -Proxy server
    Proxy server address sip: proxy01.sipphone.com
    Realm proxy01.sipphone.com
    user name: Your phone number (like 1747xxxxxx)
    password: your account password
    allow loose routing No
    Transport type UDP
    Port: 5060

    - Registrar Server
    Proxy server address sip: proxy01.sipphone.com
    Realm proxy01.sipphone.com
    user name: Your phone number (like 1747xxxxxx)
    password: your account password
    allow loose routing No
    Transport type UDP
    Port: 5060

    I hope this can help you, those are the setting in my E65 but be careful because this phone won't connect to the SIP service on any access point, mine just work in my home (Dlink Dl-524), there is something in the firewall that block the registration process,

    good luck

Similar Threads

  1. SDK 3rd and SIP problem
    By scarex80 in forum Symbian Networking & Messaging (Closed)
    Replies: 10
    Last Post: 2006-12-14, 12:22
  2. Problem with connection timeout
    By maniac_2k in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2006-09-21, 20:12
  3. PC Suite 6.7 and ca-42 connection problem
    By kingsgarden in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2006-04-06, 16:33
  4. Problem with SIP Plug-in for Series 60 SDK 2.0
    By jalakuri in forum Symbian Tools & SDKs
    Replies: 27
    Last Post: 2005-08-22, 09:55
  5. Nokia 6310i & Mac 17" powerbook bluetooth connection problem
    By scarylittlevoices in forum Bluetooth Technology
    Replies: 1
    Last Post: 2003-08-21, 14:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •