×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    s60 3rd - weired behaviour reading cell id in wcdma (umts) network

    I made an application that displays the currently logged in cell id and lac and some more data. The display is updated about once a second. This works great using the CTelephony API. (In GSM and UMTS networks.) The GSM cell ids are in the range from 10000 to 99999 and the UMTS cell ids are in the range from 100000 to 999999 on my network provider.

    It still works if I open a network connection using GPRS over GSM. However if the cell phone is connected to an UMTS network and my application (or another application) is transferring some data in background, the API delivers always a cell id of 0 and a lac of 0. Here is what I get:

    Active GPRS connection (GSM) / no data transfered: get valid cell id
    Active GPRS connection (GSM) / data transfered : get valid cell id
    Active UMTS connection / no data transfered: get valid cell id
    Active UMTS connection / data transfered: get an empty cell id (0)!

    Is this a known problem? Does anybody made the same experiences? Is there a workaround for this? If needed I can provide the part of my source where the cell id is read.

    I'm using a Nokia N80 (V4.0632.0.38) to do the tests.
    Thanks for any hints
    Last edited by rvogt; 2007-03-28 at 08:35.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Re: s60 3rd - weired behaviour reading cell id in wcdma (umts) network

    In the meantime I back ported my application to symbian os 8.0. And I get a very similar effect. I get correct cell ids as long as I do not transfer any data over WCDMA (UMTS). As soon as I transfer any data (from my application or another one in the background) the cell id is not updated anymore and stays on the same cell forever. As soon as i stop transferring data the cell id is again updated to the correct one. (The signal level is updated all the time.)
    (Edit: The same thing happens during an active call, I get no actual cell informations)
    It works well in GSM coverage even if I transfer data.
    So does anybody knows: Is this a technical problem? It should be possible to read the current cell id even during data transfers, shouldn't it?
    All the different freeware applications I have tried shows the same effect. The cell id is not updated during data transfers in WCDMA networks. So this seems to be a technical limitation or maybe a problem/error in Symbian OS.

    Edit: Same problem on N95. The cell information is not updated during data transfers if in WCDMA network.

    I still have not found a solution on how to read cell information during an active data transfer. Anybody else?
    Last edited by rvogt; 2007-05-22 at 13:06.

  3. #3
    Registered User
    Join Date
    Jan 2004
    Location
    The surburbs of Bangkok, Thailand
    Posts
    135

    Re: s60 3rd - weired behaviour reading cell id in umts network

    I'm observing the same/similar problem: cell id doesn't update during phone calls.

    My friend suggested that it's related to: http://wiki.forum.nokia.com/index.ph..._network_usage

    I tried what the document said as:

    "In some situations canceling the pending network information change notification request followed by a call for retrieving the current network information can help restore the device’s location awareness."

    ...Unfortunately that didn't help - the problem was the same on the E61 and N73 I tested.

    Any other solutions?
    Liberate yourself from the enslavement of World Monopoly!

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    39

    Re: s60 3rd - weired behaviour reading cell id in umts network

    Hi guys,
    I've the same problem.
    In UMTS during a voice call the cellid and lac are always 0.
    In GMS/GPRS/EDGE during a voice call the cellid and lac are getted correctly.

    Does anybody know a solution/workaround to this problem?

    Thanks

    Giovanni

  5. #5
    Registered User
    Join Date
    Jan 2004
    Location
    The surburbs of Bangkok, Thailand
    Posts
    135

    Re: s60 3rd - weired behaviour reading cell id in umts network

    I think there's no "open" work around for this on those phones.

    I observed that the problem (cell id during voice call) is fixed on 6210 Navigator, you can try the S60 fp2 phones, please share your results here too.
    Liberate yourself from the enslavement of World Monopoly!

Similar Threads

  1. Network Problem in 3rd Ed. Emulator
    By twlai in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2007-01-31, 15:11
  2. What is going on with Vibration on S60?
    By amd_rikus in forum Mobile Java General
    Replies: 3
    Last Post: 2006-06-16, 00:29
  3. S60 3rd edition and JSR-179
    By gregatmdl in forum Mobile Java General
    Replies: 1
    Last Post: 2006-06-14, 00:24
  4. Setting Network in 3rd SDK
    By jawir212 in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-06-08, 11:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×