×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    10

    Angry 5300 (s40) playing audio problem

    (5300 not 3500)

    hello all,
    I am trying to play audio that is to be downloaded to the mobile and saved to the RMS, then played...
    the problem started with an exception while writing to the RMS, and after some searching I realized that the mobile's RMS can handle a limited amount of data approximately 200K...

    that problem was solved by splitting the data (audio file) into parts and loading them afterward to the heap -through a byte array- for playing the audio.
    The problem is still alive,,,

    Considering that I am still loading the whole file to the heap, I implemented an InputStream that reads from different RMSs, and giving it to the Manager.createPlayer() method, but no way....

    where is the problem???
    any help please...
    Last edited by ahmadi2c; 2007-03-07 at 08:34. Reason: mistaken mobile type written in title

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: 3500 (s40) playing audio problem

    Hi ahmadi2c! Welcome to Nokia Discussion Boards!!

    Have you tried with small audio files, does they work fine?

    I could not find Nokia 3500(may be I missed!) or is it a 5300?

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    10

    Re: 3500 (s40) playing audio problem

    Quote Originally Posted by balagopalks
    Hi ahmadi2c! Welcome to Nokia Discussion Boards!!

    Have you tried with small audio files, does they work fine?

    I could not find Nokia 3500(may be I missed!) or is it a 5300?

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.
    I'm so sorry, its 5300, and it doesn't play small files...
    but in the straightforward way (without dividing the file into more than one RMS) it was playing the small files.

    you might think that there is something wrong with the new code, but no, we tested our new code on other mobiles and it works...
    Last edited by ahmadi2c; 2007-03-07 at 08:15.

Similar Threads

  1. Audio playing over RTP on 6600 and 6620.
    By ravinathwani in forum Symbian Media (Closed)
    Replies: 5
    Last Post: 2008-05-24, 09:49
  2. Problem recording audio
    By bps4484 in forum Symbian
    Replies: 1
    Last Post: 2006-08-08, 15:47
  3. Replies: 1
    Last Post: 2006-06-26, 07:41
  4. capture audio on S40 6101
    By lreyero in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2006-04-04, 18:09
  5. Audio Uplink Problem
    By kiranpuranik in forum Symbian
    Replies: 11
    Last Post: 2005-11-14, 02:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×