Truphone (http://www.truphone.com/) is a Symbian S60 3rd ed. application for making VoIP calls. See http://www.truphone.com/scn/more_info/tech.tru for technology overview.

On Truephone's support page http://www.truphone.com/scn/more_info/what_phones.tru they state that in order for Truephone to work, certain phones need specific new firmware versions. For example: "on the E60 and E61, you will need firmware version 2.0618.06.05 or later". They also instruct end-users to update their phones using Nokia Software Updater, so that they can get Truphone running.

Would anyone have any idea about from where these firmware version requirements come? Have there been major bugs in earlier phone firmware versions, that prevent applications like Truephone from working properly? Or have there been any additions in the APIs that are available in newer firmware versions on S60 3rd ed. phones?