×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2006
    Location
    Zurich, Switzerland
    Posts
    28

    Metrowerks CW - Linker error : undefined symbol

    Dear all


    I am writing an s60 Application using Metrowerks CW OEM Edition.
    When I make the project I get an "Undefined symbol:"error


    Solved: manually add libs to project by right clicking the subfolder within folder libraries
    Last edited by glmuelle; 2007-03-10 at 16:59.

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: Metrowerks CW - Linker error : undefined symbol

    It would be better if you post this in Symbian C++ section of the Discusion Boards
    http://discussion.forum.nokia.com/fo...isplay.php?f=6
    Hope our moderators will move this accordingly.

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.

  3. #3
    Registered User
    Join Date
    Jan 2006
    Location
    Zurich, Switzerland
    Posts
    28

    Re: Metrowerks CW - Linker error : undefined symbol

    i've solved the problem,

    thx

  4. #4
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: Metrowerks CW - Linker error : undefined symbol

    Even though you have solved your problem, why dont you share it here how it was solved, so that it will be of some help for some one searching hear later regarding the same topic. And why you removed a certain portion of your first post ?

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.

  5. #5
    Registered User
    Join Date
    Jan 2006
    Location
    Zurich, Switzerland
    Posts
    28

    Re: Metrowerks CW - Linker error : undefined symbol

    Hi

    I removed it because the other guy told me it was wrong here..
    And besides I posted the solution down there...


    So in general:


    If you get a linker error

    "undefined Symbol : CEikLabel::..."


    Do this:

    Right click one of the subfolders of the folder libraries in CodeWarrior chosse add files...
    and the add in this case for symbol CEikLabel the File eikcoctl.lib..

    Thx

    G

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Metrowerks CW - Linker error : undefined symbol

    As simple as that ... and not exactly correct :)

    The library should be added to the MMP file and then the project should be re-imported (there is a dedicated menu option for this task), otherwise managing the project is going to be a mess.

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. Fail to build syexpat 1.3 under 2nd FP3
    By harry_zhang in forum Symbian
    Replies: 10
    Last Post: 2010-03-19, 10:24
  3. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  4. error LNK2001: Please Help
    By sourish_khan in forum Symbian
    Replies: 9
    Last Post: 2006-04-19, 11:16
  5. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×