×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Problem with creating a theme in Carbide.ui

    Hello

    Got myselfa few days ago a E65 and since im no fan of the default hemes i decided to make one suitable for my taste, henche downloaded carbide.ui 3.1.1

    no the trouble is tha altough i get the theme in idle screen look just right if i send it to the phone the upper part of the theme is wrong size

    http://dorm.ottomar.ee/~fireman/Eraldi/problem.JPG

    the are im talking about is the idle status area background.

    when the theme is in the phone the part that is above the navi pane goes out of size. i tried both ways, keep aspect ratio and stretch, no good either way.

    hope someone can help me, thank you in advance

  2. #2
    Regular Contributor
    Join Date
    Mar 2007
    Location
    Brazil
    Posts
    66

    Re: Problem with creating a theme in Carbide.ui

    Could you send a screenshot of the theme on the phone?
    Could you also provide the picture you're using?

    We have made a few themes for E65 and they all look fine.

    Jackson

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: Problem with creating a theme in Carbide.ui


  4. #4
    Registered User
    Join Date
    Sep 2006
    Posts
    40

    Re: Problem with creating a theme in Carbide.ui

    Hello,
    Here is a short explanation and walkthrough for Your problem.

    E65 phone is a 3rd Edition phone and preview corresponds to 3rd Edition Feature 1. There are small differences in layout, few pixels that, unfortunately, You have experienced when using stretch modes and bitmaps.
    On the picture http://dorm.ottomar.ee/~fireman/Eraldi/problem.JPG it looks like there is a sliced bitmap pasted to "Idle Status Area" background.
    If "Idle Status Area" is cleared (to set to default state, invoke Clear action), It is fully transparent and it would present big image from "Idle Background", with no problems.

    Walkthrough 1(from Your current state):
    1)- leave pasted image on "Idle Background"
    2)- Select element "Idle Status Area" and invoke action Clear.
    3)- Select element "Idle Navipane" (or Navi Pane" if You are not using both), clear it (then it will turn to blue) and then follow the instructions from Properties' tooltip how to achieve transparency - add background layer or how to clear it.


    Walkthrough 2(if You start from blank theme):
    1) paste image to "Idle Background"
    2) step 3) from Walkthrough 1.
    Hope this helps.
    Best Regards,
    Aleksandar

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: Problem with creating a theme in Carbide.ui

    Ok manged to get trough the trancparency part but tha does not seem to be the problem.

    looks like idle status area background itself is the problem because after getting the navipane transparent the status area background is still out of size (and now its also seen under the navi pane)

    thats how it looks now

    http://dorm.ottomar.ee/~fireman/Eral...enshot0002.jpg

    EDIT:

    its only a wild guess but it looks like E65 has problems with themes

    after trying out warious other themes it looks like all of em have the same problem

    EDIT2:

    figured it out, atelast for me and E65

    the problem is that the ilde status area background size is different than carbide offers me. to be precise 240 X 77
    my guess is that E65 counts the space between the navipane and the first column separator also as idle status area background

    EDIT3:

    Can someone who has a Nokia E65 test the following theme. i got it look ok in my own E65 but it would be good to have a second opinion

    http://dorm.ottomar.ee/~fireman/Eraldi/Sword.sis
    Last edited by Tuletegija; 2007-03-16 at 22:37.

  6. #6
    Registered User
    Join Date
    May 2007
    Posts
    1

    Re: Problem with creating a theme in Carbide.ui

    Hi,

    I'm new to the Forum's and new to creating themes for the E65. I was wondering if you might be able to help me out with a problem I am currently facing. I've downloaded the new version of Carbide and started creating my theme.

    After completion I create the sis file and transfer it to the phone, when i try to install the theme an error message appears stating that the "Application is busy" and the phone freezes

    I than thought maybe it didn't like my theme so I just changed the idle background and created the sis file and transferred, when I try to select the theme I get another error message stating "Theme corrupted"

    So if you have any ideas I would love to hear them as I really want to customise my own theme as I previously did on my nokia 6680.

  7. #7
    Registered User
    Join Date
    Mar 2007
    Posts
    5

    Re: Problem with creating a theme in Carbide.ui

    Hmm thats something new to me. As for me i never had this kind of trouble.

Similar Threads

  1. Series 60 Theme Studio ringtone problem
    By sgerr in forum Symbian
    Replies: 0
    Last Post: 2005-01-26, 14:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×