×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    11

    KERN-EXEC 3 problem again...

    I have installed S60_3rd_FP1 SDK(for WINSCW) and then Carbide.c++ express v1.1 IDE. After some problems with environment variables, I managed to set them correctly and compile basic HelloWorld application(from command line):

    bldmake -v bldfiles
    abld build winscw udeb

    There is no problem with compilation whatsoever now(or so it seems - no errors). However, I can't launch (issuing command "epoc" from the path where abld was called) any application because of the well-known KERN-EXEC 3 error. They say that this error does not affect the emulator usage, but how can it possibly not affect the emulator usage when the test application simply does not work. Maybe there is some very, very basic thing I should know. Maybe it's so obvious that they don't even write about it ;P

    Also, after some time of using Carbide.c++ IDE(without any success in attempts to run applications in the emulator), creating new projects became impossible:

    "No SDKs were found. Check your SDK Preferences page to see if you have at least one valid and enabled SDK for this project type."

    In window->Preferences->carbide.c++->SDK Preferences, there is the following:

    Discovered Symbian OS SDKs:

    S60_3rd_FP1_5

    SDK Information:

    C:\Symbian\9.2\S60_3rd_FP1_5
    Build configuration: S60_31

    This is my devices.xml file:

    <?xml version="1.0" encoding="UTF-8"?>
    <devices version="1.0">
    <device id="S60_3rd_FP1_5" name="com.nokia.s60" default="yes" userdeletable="no">
    <epocroot>C:\Symbian\9.2\S60_3rd_FP1_5\</epocroot>
    </device>
    </devices>

    I've tried to start with Symbian for a week now and it's extremely confusing. I've read all the posts related to the infamous "KERN-EXEC 3" and none of them was of any help.

    Thank you in advance for any tips.

  2. #2
    Registered User
    Join Date
    Mar 2007
    Posts
    11

    Re: KERN-EXEC 3 problem again...

    I Think, that it's also worth mentioning that running eshell doesn't help either. There is a panic after I run emulator and it switches back to gui mode(if that makes any sense).

Similar Threads

  1. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  2. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  3. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  4. please help! setting page issue (checkbox) kern exec 3
    By flicker82 in forum Symbian User Interface
    Replies: 4
    Last Post: 2005-02-10, 12:57
  5. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×