×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    7

    old hand trying new stuff... needs help

    Ok and hi to all that use this forum

    im new to all this symbian stuff but not
    to programming.
    It seems pretty interesting but im already
    baffled at the very start

    i have downloaded and installed
    1, carbide c++ ide
    2, ActivePerl-5.6.1.635-MSWin32-x86.msi
    3, S60-SDK-0548-3.0-f.3.215f.zip

    when i run carbide it says words to this effect
    "pearl was not found in your path. symbian build tools
    cannot work without pearl" then it goes on to say i have
    to install pearl and re run carbide

    since i have already (and a few times) install and reinstalled
    ActivePerl-5.6.1.635 i cannot see what i have done/doing wrong
    i looked in the carbide pref. to see if there was some sort of
    browse box to point it to but did not see any.

    can someone point me in the correct direction please, on how
    to setup carbide c++ that it runs with no errors

    Thanks you
    Nokeya

  2. #2
    Regular Contributor
    Join Date
    Oct 2003
    Location
    Spain
    Posts
    329

    Re: old hand trying new stuff... needs help

    Hi,

    Add C:\Program Files\Perl\bin\ to the PATH user enviroment variable (or whenever you have installed perl).

    Bye

  3. #3
    Registered User
    Join Date
    Apr 2007
    Posts
    7

    Re: old hand trying new stuff... needs help

    ajsanchez
    thanks for the reply.
    however the windows system/user environment variables
    maybe giving me a warning that i should not try to
    code for symbian

    im still stuck, this is what i have tried so far.
    i have placed the path with the location of perl
    g:\Program\Perl\bin\perl5.6.1.exe;g:\Program\CSL Arm Toolchain\bin;C:\Program\Delade filer\Symbian\Tools;C:\Program\PC Connectivity Solution\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program\QuickTime\QTSystem\

    in other attempts i have placed it in the user section as
    g:\Program\Perl\bin\perl5.6.1.exe and the same for the system section on
    another try

    finaly i went to perl installation documentation page and reinstall it again
    with there line command
    msiexec /i msi_file.msi TARGETDIR="c:\perl" PERL_PATH="Yes"

    yet still carbide throws up the missing perl error box

    can anyone please tell me whats wrong. im using winxp home
    all i want to do is start writing for the s60:

    thanks in advance
    Nokeya

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: old hand trying new stuff... needs help

    Can you run the Perl Command on Command Line. Try to fix the Path So that you can run Perl from Command line with out any problem.

  5. #5
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: old hand trying new stuff... needs help

    Quote Originally Posted by nokeya
    im still stuck, this is what i have tried so far.
    i have placed the path with the location of perl
    g:\Program\Perl\bin\perl5.6.1.exe;g:\Program\CSL Arm Toolchain\bin;C:\Program\Delade filer\Symbian\Tools;C:\Program\PC Connectivity Solution\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program\QuickTime\QTSystem\

    in other attempts i have placed it in the user section as
    g:\Program\Perl\bin\perl5.6.1.exe and the same for the system section on
    another try
    If the path for your perl installation is correct then I think the problem is with the bolded part on the above quote. Remove that from the path environment variable and try again.

  6. #6
    Registered User
    Join Date
    Apr 2007
    Posts
    7

    Re: old hand trying new stuff... needs help

    Hi
    i returned to say thank you for all the help.

    the situtation is now solved. it appeared that
    my winxp system was messed up.

    after trying everything and failed i recalled
    a previous windows ghost image and tried the
    whole installation again, this time perl the sdk's, and
    ctags56 paths were all picked up by carbide.c++
    with no errors at all.

    now its time for me to mess up my symbian phone
    so i guess you will be hearing from me in the future

    so thank you again
    Nokeya

  7. #7
    Registered User
    Join Date
    Jul 2008
    Location
    Czech Republic
    Posts
    14

    Re: old hand trying new stuff... needs help

    Hi guys, please help me. I'm getting the same error as my collegue. The difference is that I really don't understand how to do this:

    "Add C:\Program Files\Perl\bin\ to the PATH user enviroment variable (or whenever you have installed perl)."

    I'm sorry, I'm a newbie, economist.

    Can you give me simple tutorial? Thanks a lot.

  8. #8
    Nokia Developer Champion
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,545

    Re: old hand trying new stuff... needs help

    In Windows you can edit the PATH statement via Control Panel: Start > Settings > Control Panel > System > Advanced > Environment Variables.

  9. #9
    Registered User
    Join Date
    Jul 2008
    Location
    Czech Republic
    Posts
    14

    Re: old hand trying new stuff... needs help

    Thank you very much. I moved forward a bit.

    Now, I have another problem, I will make a new thread.

Similar Threads

  1. Which Symbian SDK support JNI stuff?
    By anand_zain76 in forum Symbian C++
    Replies: 1
    Last Post: 2006-08-10, 14:15
  2. Jar file contains a lot of stuff
    By LiveRock in forum Mobile Java General
    Replies: 1
    Last Post: 2006-04-14, 09:20
  3. Where to find homemade stuff?
    By morteniversen82 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2005-11-18, 07:59
  4. Resources and stuff
    By edi678 in forum Mobile Java General
    Replies: 0
    Last Post: 2005-01-17, 21:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •