×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    8

    problem in playing mp3 in 6230i

    Hi everyone,

    I have developed a simple player using Jsr 75 pdaapi and Jsr 135 mmapi to play media in device. I use Class Player player = Manager.createPlayer(istream, ctype) with ctype = "audio/mpeg" to play mp3 in Nokia 6280 and it works just fine.
    Then I find Nokia 6230i not support content type "audio/mpeg", but "audio/mpeg3". However, neither I use ctype = "audio/mpeg3" nor "audio/mpeg", it don't play any sound.

    Please help me out, thanks !
    Bests,
    double d

  2. #2
    Registered User
    Join Date
    Mar 2007
    Posts
    8

    Re: problem in playing mp3 in 6230i

    Hey, I finally can play mp3 with "amr" in emulator "Nokia_S40_DP20_SDK_6230i" in WTK25, but not the real handset. it throws MediaException.
    I have tried "amr", "mpeg3", "mp4" and "wav" in device.
    But all throw MediaException. Will it possible be the problem with the inputStream?

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    8

    Re: problem in playing mp3 in 6230i

    I actrully do in this way,

    Code:
    fc = (FileConnection)Connector.open(path, Connector.READ);
    thePlayer.choosePlayer(fc.openInputStream(), type);
    where fc is a FileConnection, path is a file path, type is content type where I suspect the bug in.

    these codes work fine with Nokia 6280 with type = "audio/mpeg".

Similar Threads

  1. Not Playing all my MP3 Files !
    By titani2 in forum Audio
    Replies: 3
    Last Post: 2007-04-09, 16:08
  2. Question about playing mp3 to the uplink
    By goodtaste in forum Symbian Media (Closed)
    Replies: 9
    Last Post: 2007-02-14, 01:29
  3. 6280 problem playing 3pg
    By raphael_c in forum General Development Questions
    Replies: 1
    Last Post: 2006-04-04, 09:07
  4. AAC, MP3 playback problem on N71
    By josephtkc in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2006-02-17, 06:41
  5. MP3 or MIDI NOt POssible in MMS 6230i !
    By zigid in forum General Development Questions
    Replies: 12
    Last Post: 2005-07-11, 20:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •