×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Exclamation import java.security.*; & import java.math.*;

    How can i import it?

    Error on WTK:
    package java.security does not exist import java.security.*;
    package java.security does not exist import java.math.*;

    Tks!

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Israel
    Posts
    2,280

    Re: import java.security.*; & import java.math.*;

    You can't import J2SE/J2EE packages that are not part of J2ME.

    shmoove

  3. #3
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Re: import java.security.*; & import java.math.*;

    then wht should i import?
    and how to do???

    Tks!

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Re: import java.security.*; & import java.math.*;

    And i would like to ask... the JCE which is not already integrate in the JDK1.5?
    if not how can i install in it?

  5. #5
    Nokia Developer Expert
    Join Date
    Jun 2005
    Posts
    923

    Re: import java.security.*; & import java.math.*;

    Please read the CLDC and MIDP javadocs before posting the same types of questions (Is package X available?) in several places.

    Those javadocs are available in any Nokia SDK.

    Daniel

  6. #6
    Regular Contributor
    Join Date
    Dec 2009
    Posts
    77

    Re: import java.security.*; & import java.math.*;

    I am getting the same exception

    java.security.InvalidKeyException;
    javax.crypto.* doesnt exist

    In this thread they have given JCE what is that...please tell anyone...

    And i am using jdk 6 version ....
    Please anyone give solution

  7. #7
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: import java.security.*; & import java.math.*;

    What Wireless Toolkit (or Java ME SDK / Nokia SDK / etc.) are you using? For what device are you developing?

    The classes you're trying to import only exist on devices (or SDKs) that support the optional cryptography component of JSR-177 (Security And Trust Services API, SATSA).

    You might just need to add this library to your project's build-path.

    Graham.

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. Bluetooth is a problem in j2me, especially in games
    By memosen80 in forum Mobile Java General
    Replies: 8
    Last Post: 2007-01-27, 18:50
  3. SyExpat + problem + memmove + Carbide Express
    By pearman in forum Symbian
    Replies: 2
    Last Post: 2006-10-14, 22:21
  4. DemoDMServer SMS problem
    By kudelasz in forum OMA DM/DS/CP
    Replies: 17
    Last Post: 2006-05-22, 09:16
  5. SocketConnection Work on 6600&Emulators BUT NOT IN 6680
    By eerant in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2006-03-11, 00:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •