×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    build of examples fails

    Hi all!

    I've installed Nokia 9200 Communicator series SDK 1.2 (with symbian
    6.0) and Perl on a computer running Windows 2000. It gives a warning
    about not being supported on W2000 but installs ok.

    When I try to build HelloWorld example (or any other) it produces
    the following output:

    Microsoft Windows 2000 [Version 5.00.2195]
    (C) Copyright 1985-2000 Microsoft Corp.

    C:\>cd symbian\6.0\nokiacpp

    C:\Symbian\6.0\NokiaCPP>cd epoc32ex

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex>cd crystalui

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI>cd helloworld

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>bldmake bldfiles

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>dir
    Volume in drive C has no label.
    Volume Serial Number is 8054-51A3

    Directory of C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld

    11/03/2002 05:21p <DIR> .
    11/03/2002 05:21p <DIR> ..
    11/03/2002 05:22p 339 ABLD.BAT
    06/07/2001 04:47p 114 Bld.inf
    06/07/2001 04:47p 2,587 HelloWorld.h
    06/07/2001 04:47p 283 HelloWorld.hrh
    06/07/2001 04:47p 622 HelloWorld.mmp
    06/07/2001 04:47p 2,095 HelloWorld.rss
    06/07/2001 04:47p 1,103 HelloWorld_Application.cpp
    06/07/2001 04:47p 2,457 HelloWorld_AppUi.cpp
    06/07/2001 04:47p 3,092 HelloWorld_AppView.cpp
    06/07/2001 04:47p 1,080 HelloWorld_Document.cpp
    06/07/2001 04:47p 1,248 HelloWorld_Main.cpp
    11 File(s) 15,020 bytes
    2 Dir(s) 51,497,556,480 bytes free

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>abld build wins
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" MAKEFILE VERBOSE=-s
    perl -S makmake.pl -D \SYMBIAN\6.0\NOKIACPP\EPOC32EX\CRYSTALUI\HELLOWORL
    D\HELLOWORLD WINS
    Bad command or file name
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" LIBRARY VERBOSE=-s
    nmake -nologo -s -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOK
    IACPP\EPOC32EX\CRYSTALUI\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" LIBRARY
    NMAKE : fatal error U1045: spawn failed : Invalid argument

    Stop.
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" RESOURCE CFG=UDEB VERBOSE=-s
    nmake -nologo -s -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOK
    IACPP\EPOC32EX\CRYSTALUI\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" RESOURCEUDE
    B
    NMAKE : fatal error U1045: spawn failed : Invalid argument

    Stop.
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" RESOURCE CFG=UREL VERBOSE=-s
    nmake -nologo -s -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOK
    IACPP\EPOC32EX\CRYSTALUI\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" RESOURCEURE
    L
    NMAKE : fatal error U1045: spawn failed : Invalid argument

    Stop.
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" TARGET CFG=UDEB VERBOSE=-s
    nmake -nologo -s -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOK
    IACPP\EPOC32EX\CRYSTALUI\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" UDEB
    NMAKE : fatal error U1045: spawn failed : Invalid argument

    Stop.
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" TARGET CFG=UREL VERBOSE=-s
    nmake -nologo -s -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOK
    IACPP\EPOC32EX\CRYSTALUI\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" UREL
    NMAKE : fatal error U1045: spawn failed : Invalid argument

    Stop.
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" FINAL CFG=UDEB VERBOSE=-s
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\WINS.make" FINAL CFG=UREL VERBOSE=-s

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>
    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>
    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>abld makefile vc6
    nmake -nologo -f "\Symbian\6.0\NokiaCPP\EPOC32\BUILD\SYMBIAN\6.0\NOKIACPP\EPOC
    32EX\CRYSTALUI\HELLOWORLD\VC6.make" MAKEFILE VERBOSE=-s
    perl -S makmake.pl -D \SYMBIAN\6.0\NOKIACPP\EPOC32EX\CRYSTALUI\HELLOWORL
    D\HELLOWORLD VC6
    Bad command or file name

    My environment looks like this:
    -------------------------------

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>set
    ALLUSERSPROFILE=C:\Documents and Settings\All Users
    APPDATA=C:\Documents and Settings\Ulf Nikander\Application Data
    CommonProgramFiles=C:\Program Files\Common Files
    COMPUTERNAME=UNASUS
    ComSpec=C:\WINDOWS\system32\COMMAND.COM
    EPOCROOT=\Symbian\6.0\NokiaCPPHOMEDRIVE=C:
    HOMEPATH=LOGONSERVER=\\UNASUS
    NUMBER_OF_PROCESSORS=1
    OS=Windows_NT
    Os2LibPath=C:\WINDOWS\system32\os2\dll;
    Path=C:\Perl\bin;C:\Program Files\Microsoft Visual Studio\VC98\bin\;C:\Program F
    iles\Microsoft Visual Studio\Common\msdev98\bin\;C:\Program Files\Microsoft Visu
    al Studio\Common\tools\;C:\Program Files\Microsoft Visual Studio\Common\tools\wi
    nnt\;C:\WINDOWS\;C:\WINDOWS\COMMAND\;C:\WINDOWS\system32\;C:\WINDOWS\system32\WB
    EM\;C:\Program Files\Common Files\Adaptec Shared\System\;C:\Program Files\Symant
    ec\pcAnywhere\;C:\Symbian\6.0\Shared\epoc32\tools;C:\Symbian\6.0\Shared\epoc32\g
    cc\bin;
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
    PROCESSOR_ARCHITECTURE=x86
    PROCESSOR_IDENTIFIER=x86 Family 6 Model 6 Stepping 2, AuthenticAMD
    PROCESSOR_LEVEL=6
    PROCESSOR_REVISION=0602
    ProgramFiles=C:\Program Files
    PROMPT=$p$g
    SystemDrive=C:
    SystemRoot=C:\WINDOWS
    TEMP=c:\windows\temp
    TMP=c:\windows\temp
    USERDOMAIN=UNASUS
    USERNAME=Ulf Nikander
    USERPROFILE=C:\Documents and Settings\Ulf Nikander
    winbootdir=C:\WINDOWS
    windir=C:\WINDOWS
    WPCEmulDir=C:\Windows CE Tools\wce300\MS Pocket PC\emulation

    C:\Symbian\6.0\NokiaCPP\Epoc32Ex\CrystalUI\HelloWorld>


    What am I missing here? Or what am I doing wrong?
    Something missing from the PATH? Can't find anywhere
    info on what should be in env, only that install procedure sets
    it up 'correctly'. Really frustrating :-(

    Greatful for any ideas!
    Uffe

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    RE: build of examples fails

    Thanks a lot, for nothing!

    If some of you 'gurus' would had taken a look at this you probably
    would have spotted the problem. But no.

    Ok, no use to be nasty. I finally found the problem myself.
    Probably because my installation is not a clean installation but
    an upgrade I had the COMSPEC set to "C:\windows\system32\command.com".
    I noticed that many of the perl scripts check that it is
    "%systemdir%\system32\cmd.exe" and exit if not. So setting COMSPEC to
    "C:\windows\system32\cmd.exe" solved the problem :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×