×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    2

    Running emulator under SDK 1.0

    Anyone successfully run the Emulator using the SimpleNDEFExample? If so, what model of the Omnikey CardMan card reader did you use (CardMan CM5321 USB?). Looks like it won't launch unless a reader is attached. Thanks.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    53

    Re: Running emulator under SDK 1.0

    You don't need to use any external card reader to run the example SimpleNDEFExample.
    Emulator has the role of card reader and NFC card (Mifare Ultralight) is also emulated through the emulator.

    Read the release notes (in the directory /examples/SimpleNDEFExample/) to see how to write and read operations can be made.

    - yakdogan

  3. #3
    Regular Contributor
    Join Date
    Mar 2007
    Location
    Helsinki, Finland
    Posts
    91

    Re: Running emulator under SDK 1.0

    The Nokia 6131 NFC SDK 1.0 supports Omnikey CardMan 5x21 external readers. When you install the drivers for your Omnikey CardMan reader, please make sure you also install the CardMan Synchronous API, which gives the NFC SDK a way to communicate with supported RFID cards. Section 2.1 (Installing and Omnikey CardMan reader) in the User’s Guide contains more information about the two-step installation procedure required for this type of external reader.

    However, the Nokia 6131 NFC Emulator can be run even if there is no external reader attached. You can launch the SimpleNDEFExample and use the simulated cards to read and write NDEF records. When you say that the Emulator won’t launch if there is no reader attached, what do you mean? Is there any (error) message? Can you please give us more details?
    Raluca Cindrea
    Helsinki, Finland
    www.nokia.com/nfc

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    2

    Re: Running emulator under SDK 1.0

    When I launch the Nokia SDK Launcher I see the phone and select file > open navagating to the jad file for the SimpleNDEFExample. The picture of the phone disapears and whats shown in the emulator window is the commend to execute the midp.exe with a Xdescriptor that points to the .jad file I navagated then eventually a emulator closed message appears. Sorry I can't seem to cut and past the message that appears. I am using a 1.5 JDK with Eclipse 3.2.2. The plugin installed correctly I was able to open up the SimpleNDEFExample in Eclipse, compiles fine. I tried to launch the eumlator from Eclipse with no luck either. Same command appears in the, I turned trace options on and even set break points in the code but it doesn't look like the emulator even launches into the code

    One last note when I launch the emulator it shows a picutre of a closed 6131 phone it doesn't look anything like the one pictured on page 12 of the Nokia 6131 SDK User's Guide v1.0 3/27/07. Does it flip open when the example launches? Might be an error between the chair and the key board but I am stumped. Thanks

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    1

    Re: Running emulator under SDK 1.0

    Is there anyone using the "Pegoda reader" to exchage APDU with the card successfully? I see the "Pegoda reader" is in Supported external card readers list in "Nokia 6131 NFC SDK User Guide."

    But when I use pegoda reader to work with emulator, it seems that the emulator doesn't find the reader yet.

  6. #6
    Regular Contributor
    Join Date
    Mar 2007
    Location
    Helsinki, Finland
    Posts
    91

    Re: Running emulator under SDK 1.0

    Quote Originally Posted by yuchansung
    Is there anyone using the "Pegoda reader" to exchage APDU with the card successfully? I see the "Pegoda reader" is in Supported external card readers list in "Nokia 6131 NFC SDK User Guide."

    But when I use pegoda reader to work with emulator, it seems that the emulator doesn't find the reader yet.
    The Pegoda reader can be used with the emulator if you want to read/write tags, but for exchanging APDUs with a smart card you have to use an Omnikey reader.

    Also, please note that currently the only smart card that you can use to get an ISO14443Connection through an external reader (Omnikey) when using the emulator is the JCOP 3.0.

    I hope this helps.
    Raluca Cindrea
    Helsinki, Finland
    www.nokia.com/nfc

Similar Threads

  1. SIP Plug-in SDK 1.0 and 2.0_CW no more available?
    By Paulour in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-12-13, 08:47
  2. Carbide 1.5 and NFC SDK 1.0
    By ivanmilara in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-11-30, 10:30
  3. running nokia series 60 MIDP SDK from the command line
    By warner_godfrey in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-05-05, 03:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •