×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    11

    Question S60 3rd ed. sample app not working on emulator

    Hi,

    I downloaded and installed S60 3rd edition FP1 SDK. It got installed properly.
    When I try to compile the "HelloWorldBasic" sample application using the steps as given in InstallationGuide, I get the result:

    C:\>cd \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group

    C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group>bldmake bldfiles

    C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group>abld build
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do


    But when I open the emulator, the icon for application is not there.
    Same is happening for other examples too (I tried MultiViews application too).

    Can someone pls help.

    Thx,
    VC.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Smile Re: S60 3rd ed. sample app not working on emulator

    Hi,

    Try following sequence:

    bldmake bldfiles
    abld build winscw udeb
    epoc
    I hope you would find your application icon under "Installation" folder from within your Emulator.

    Kiran.

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    11

    Re: S60 3rd ed. sample app not working on emulator

    Hi Kiran,

    As suggested by you, I tried "abld build winscw udeb".

    However, I got the following error:

    C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group>bldmake bldfiles

    C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group>abld build winscw udeb
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\WINSCW.make" MAKEFILE VERBOSE=-s
    make -s -C \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group -f "ICONS_SCALA
    BLE_DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.2\S60_3
    rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\ICONS_SC
    ALABLE_DC\WINSCW TO_BLDINF=..\..\..\..\..\..\Symbian\9.2\S60_3rd_FP1\S60Ex\Hello
    WorldBasic\group PLATFORM=WINSCW MAKMAKE
    perl -S makmake.pl -D \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\HELL
    OWORLDBASIC WINSCW
    ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation
    make: *** [MAKEFILEHELLOWORLDBASIC] Error 255
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\WINSCW.make" LIBRARY VERBOSE=-s
    make -s -C \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group -f "ICONS_SCALA
    BLE_DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.2\S60_3
    rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\ICONS_SC
    ALABLE_DC\WINSCW TO_BLDINF=..\..\..\..\..\..\Symbian\9.2\S60_3rd_FP1\S60Ex\Hello
    WorldBasic\group PLATFORM=WINSCW LIB
    make -s -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S6
    0Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW" LIBRARY

    make[1]: \Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\Hel
    loWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW: No such file o
    r directory
    make[1]: *** No rule to make target `\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbi
    an\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLD
    BASIC.WINSCW'. Stop.
    make: *** [LIBRARYHELLOWORLDBASIC] Error 2
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\WINSCW.make" RESOURCE CFG=UDEB VERBOSE=-s
    make -s -C \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group -f "ICONS_SCALA
    BLE_DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.2\S60_3
    rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\ICONS_SC
    ALABLE_DC\WINSCW TO_BLDINF=..\..\..\..\..\..\Symbian\9.2\S60_3rd_FP1\S60Ex\Hello
    WorldBasic\group PLATFORM=WINSCW CFG=UDEB RESOURCE
    MifConv version 1.11 build (39).
    Checking: ..\gfx\qgn_menu_helloworldbasic.svg
    Choosing...
    Convert files...
    .
    Loading mif icons...
    Loading file: \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s2ig.tmp\.._g
    fx_qgn_menu_helloworldbasic.svgb
    Writing mif: \Symbian\9.2\S60_3rd_FP1\epoc32\release\WINSCW\UDEB\Z\resource\apps
    \helloworldbasic_aif.mif
    make -s -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S6
    0Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW" RESOURC
    EUDEB
    make[1]: \Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\Hel
    loWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW: No such file o
    r directory
    make[1]: *** No rule to make target `\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbi
    an\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLD
    BASIC.WINSCW'. Stop.
    make: *** [RESOURCEHELLOWORLDBASIC] Error 2
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\WINSCW.make" TARGET CFG=UDEB VERBOSE=-s
    make -s -C \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group -f "ICONS_SCALA
    BLE_DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.2\S60_3
    rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\ICONS_SC
    ALABLE_DC\WINSCW TO_BLDINF=..\..\..\..\..\..\Symbian\9.2\S60_3rd_FP1\S60Ex\Hello
    WorldBasic\group PLATFORM=WINSCW CFG=UDEB BLD
    make -s -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S6
    0Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW" UDEB
    make[1]: \Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\Hel
    loWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLDBASIC.WINSCW: No such file o
    r directory
    make[1]: *** No rule to make target `\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbi
    an\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\HELLOWORLDBASIC\WINSCW\HELLOWORLD
    BASIC.WINSCW'. Stop.
    make: *** [TARGETHELLOWORLDBASIC] Error 2
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\WINSCW.make" FINAL CFG=UDEB VERBOSE=-s
    make -s -C \Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group -f "ICONS_SCALA
    BLE_DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.2\S60_3
    rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\ICONS_SC
    ALABLE_DC\WINSCW TO_BLDINF=..\..\..\..\..\..\Symbian\9.2\S60_3rd_FP1\S60Ex\Hello
    WorldBasic\group PLATFORM=WINSCW CFG=UDEB FINAL
    Can you pls tell whats wrong.

    Thx,
    -VC.

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Smile Re: S60 3rd ed. sample app not working on emulator

    Hi,

    Install an IDE first. You can work with Code Warrior, Carbide.C++, MS.Visual 2003 IDE with Carbide.Vs support etc...

    Anyways you can try free Carbide.C++:
    http://www.forum.nokia.com/main/reso...s/carbide_cpp/

    More narrowly: http://www.forum.nokia.com/info/sw.n...p_Express.html

    After then repeate the steps.

    Kiran.

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    11

    Exclamation Re: S60 3rd ed. sample app not working on emulator

    Hi Kiran,

    Is having an IDE mandatory even for working with command prompt?

    -VC.

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,559

    Re: S60 3rd ed. sample app not working on emulator

    Quote Originally Posted by vishy_ch
    Hi Kiran,

    Is having an IDE mandatory even for working with command prompt?

    -VC.
    Well, IDE helps you walk before you can decide to run . On the more serious note, like Kiran suggested I would second his opinion that you really should get yourself an IDE..and you have some wonderful ones there..Carbide.c++ express is free and its really improved a lot in the past few months(I dont want to sound like a salesman LOL).

    Good Luck and Cheers
    Neil

  7. #7
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Smile Re: S60 3rd ed. sample app not working on emulator

    Hi VC,
    Quote Originally Posted by vishy_ch
    Hi Kiran,

    Is having an IDE mandatory even for working with command prompt?

    -VC.
    Refer to the following link for the same questions.
    http://discussion.forum.nokia.com/fo...ad.php?t=78256

    Kiran.

  8. #8
    Registered User
    Join Date
    Feb 2009
    Posts
    1

    Re: S60 3rd ed. sample app not working on emulator

    Hi,

    Long time since anyone has posted to this thread. I have the same problem with blank emulator. Has anyone found a solution?

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: S60 3rd ed. sample app not working on emulator

    Indeed, this thread happened a long time ago. Also note that its topic is not about having a blank emulator.
    If you have problems with emulator startup, a thing you can check its logfile: http://wiki.forum.nokia.com/index.php/Epocwind.out

Similar Threads

  1. Extra E90 screen size in the S60 3rd edition FP1 emulator
    By svdwal in forum Symbian Tools & SDKs
    Replies: 34
    Last Post: 2009-05-12, 08:55
  2. Installing a SIS file on the S60 3rd edition emulator
    By roey in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-03-13, 12:22
  3. Browser issue in S60 3rd edition emulator
    By sekou in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-10-13, 00:18
  4. Is E drive avaible on s60 3rd ed emulator?
    By justinlacroix in forum Symbian
    Replies: 3
    Last Post: 2006-10-06, 18:29
  5. s60 sdk 3rd ed mantainence release emulator has the blank screen
    By maniak010 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-06-22, 15:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×