×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    7650: reading SMS via AT+CPMS does not work

    Hi,

    sending SMS via AT commands works fine.

    Receiving SMS from the SIM card (SM) works also (if the SMS is saved by an other mobile phone), but the 7650 does not save incomming SMS on the SIM card. It saves incomming SMS immediately on the "MT" memory, which is not readable via AT commands:

    at+cpms="MT"
    ERROR
    at+cpms="ME"
    ERROR
    at+cpms="SM"
    +CPMS: 0,12,0,12,0,12

    And the phone seems to have no ME memory.

    How can I set the phone to save incomming SMS on the SIM?

    Thanks
    Kai
    fun communications

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    509

    RE: 7650: reading SMS via AT+CPMS does not work

    You can use class type 2 messages which go to the SIM memory
    when you send messages to 7650. Then they will end up to SIM
    memory and will be shown by AT commands.
    at+csmp=17,167,0,242
    MT parameter seems to show also only SIM messages and no ME
    messages, those are totally hidden from AT-commands by the phone.
    Unfortunately there seems to be no way in the phone to set
    preferred message storage for received messages.
    BR
    M, Forum Nokia

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Posts
    509

    RE: 7650: reading SMS via AT+CPMS does not work

    at+csmp=17,167,0,242
    This setting is especially used in Text mode sending and not in
    PDU mode, if that helps at all.
    I agree with your comment about memories and have taken this issue
    forward.
    BR
    M, Forum Nokia

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Get SMS in MT with AT command

    Hi,
    I try to get some SMS in my Symbian phone. I use the AT command.
    In first I try AT+CMGL=4, I have only my SIM card SMS.
    I want to change the setting of the CPMS command and I try AT+CPMS=MT, or MT, MT, MT but nothing works.
    Only the default value works.
    Have you any idea to solve my problem, how to copy all the SMS in SIM card, how to change the directory with AT command, or have you a software which move SMS from memory to SIM card.

    Thanks for your help

    Tony

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    SMS via AT command

    What are the feedback from Nokia to this problem ?
    How can we read the SMS via AT command from MT.

    Thanks for your help

    Tony

  6. #6
    Registered User
    Join Date
    Jun 2004
    Posts
    1
    Try using
    AT+CPMS="ME"
    It should help, "MT" means ME and SM, selective

  7. #7
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hi!

    This has been the case for Symbian devices. When the OS receive incoming SMS/email/MMS message, it will be stored to Symbian internal database. This is the root cause why user can't acces received messages. There is no AT commands available that could access these databases. Only the messages moved manually to SIM can be read from SM.

    The same thing goes for contacts as well, with a current devices user can have many different fields of information in one person, and again there is no such a AT command that could be used to read e-mail address from a contact. Only the contacts stored to SM can be seen.

    Teemu / Forum Nokia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×