×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    Problems with preinstalled packages

    I have some problems with PA packages. I have made the .sis file with type PA and all the files are in place (sis file is in \private\10202dce folder and all files are in memory card) but when I insert the mini-SD to the device the application is not installed to the phone. Application installer finds the .sis file (and claims that it is uninstalled) but when I try to install the application manually the installation fails to the error message "Unable to install". The sis file is signed with R&D certificate and the corresponding certificate is also installed into phone.

    I need to solve the problem ASAP so all the help is more than welcome.

    - Kirmo

  2. #2
    Registered User
    Join Date
    Apr 2007
    Posts
    16

    Re: Problems with preinstalled packages

    I have the same issue. I am trying everything and it does not work. I use N73.
    My application is in protected range: 0x2.....
    I use development certificate.
    Last edited by Leanid; 2007-04-19 at 21:14.

  3. #3
    Registered User
    Join Date
    Apr 2007
    Posts
    16

    Re: Problems with preinstalled packages

    I am very confused with this PA. In SDK help for symbian 3 1.0_2 there are next lines:

    "Pre-installed applications
    An application can be pre-installed to a media card before sale, in other words by the vendor rather than the end user.

    To prepare such a media card, a PKG file of type PA ('preinstalled application') is required. The PKG file must include an install-file section which lists all executables and data files. The source filenames are not relevant and can consist of empty quotes. The ! character should be used as the target drive letter for all files."

    It says to use ! as target drive, but another document tells to use e:/ as target drives.

    Also PA type .sis file supposed to create hash values for all source files to validate them on installation? So then how does it finds it if source files are not relevant and can be empty? It does not have e:/sys/bin/MyApp.exe for sure.

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    16

    Re: Problems with preinstalled packages

    Ok, looks like setting read only permissions on all preinstalled files that listed in .pkg did the trick.

    Also I named my stub installer as my app UID (might be not necessary, will try later).

    Also If you ever installed application on your phone with the same UID autoinstall will not start, but you can start it manually from App Manager or by resetting phone with ("*#7370#"), but I did not tried it myself.

    I think this is Symbian "feature", when you first time insert card with preinstalled application it installs. If user unistalled application, symbian will not try to install it automatically, but user can do it manually from App. Manager.

    I signed application with developer certificate, all functionality available, UID in protected range 0x2...

    And I used type=PA and directed all files to e: drive.

    I guess SDK help completely wrong on this issue.
    Last edited by Leanid; 2007-04-23 at 18:17.

Similar Threads

  1. CTelephony Problems in N73
    By saji_iq in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-02-07, 07:57
  2. Several problems with NMIT 4.1 MMS
    By jtalviva in forum General Messaging
    Replies: 0
    Last Post: 2006-03-10, 11:03
  3. Several problems with NMIT 4.1
    By jtalviva in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-03-10, 10:59
  4. Problems Generating Application Packages
    By MBeller in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-07-01, 11:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×