×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    WML error in Nokia9210

    In a course of testing the web application on mobile phones, we encoutered an unusual error. For the WML page below, we are getting "WML error" in Nokia 9210, but no other phone (Nokia or other) reports any errors. What is wrong with this page?

    --------------------------------------------------
    Request was:
    --------------------------------------------------
    GET to ps-support.tor.corp.cp.net:80
    Context path: /cp
    Path info: /Main/login/Login
    Path translated: /opt/jakarta-tomcat-4.0.4/webapps/cp/Main/login/Login
    Query string: l=en&d=wmltest.cp.net
    Request URI: /cp/ps/Main/login/Login
    Servlet path: /ps
    Content length: -1
    Content type: null
    Char encoding: ISO-8859-1
    Locales: en
    Default locale: en
    Remote addr: 138.188.101.29
    Remote host: 138.188.101.29
    Remote user: null
    Headers:
    x-up-uplink = 'spwapgw1p.swissptt.ch'
    host = 'ps-support.tor.corp.cp.net:80'
    x-up-devcap-max-pdu = '8192'
    accept-language = 'en'
    user-agent = 'Nokia9210/1.0 Symbian-Crystal/6.0 UP.Link/5.1.1.4'
    x-up-devcap-charset = 'utf-8'
    cookie = 's=1036508558678'
    connection = 'close'
    x-up-wappush-secure = 'www.openwave.com:9003/pap'
    accept = 'text/vnd.wap.wml, application/vnd.wap.wmlc, application/vnd.wap.wmlscriptc, image/gif, image/jpeg, image/tiff, image/png, image/vnd.wap.wbmp, image/bmp,image/vnd.wap.wbmp,text/x-hdml,text/html,text/x-wap.wml,text/vnd.wap.wml,text/vnd.wap.wmlscript, */*'
    x-up-wappush-unsecure = 'www.openwave.com:9002/pap'
    accept-charset = 'utf-8, UTF-8, *'
    Params:
    l = 'en'
    d = 'wmltest.cp.net'
    Attributes:
    loginInfo = 'net.cp.ps.main.application.beans.LoginInfoBean@44569b'
    _PS_REQUEST_CONTEXT_ = 'null@wmltest.cp.net'
    Cookies:
    s = '1036508558678'
    --------------------------------------------------
    Response was:
    --------------------------------------------------
    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml">


























    <wml>
    <head>
    <meta forua="true" http-equiv="Cache-Control" content="max-age=0"/>
    </head>
    <template>
    <do type="prev" label=" ">
    <noop/>
    </do>
    <do type="accept" label=" ">
    <noop/>
    </do>
    </template>

    <card id="splash" ontimer="#login">
    <timer value="30"/>
    <p align="center">
    <img src='/cp/images/default/en/main/layout/cp_logo_xsm.wbmp' alt='Company Logo'/>
    </p>
    <p align="left">
    Welcome!
    </p>
    <p align="left">
    <do type="accept" label='OK'>
    <go method="get" href="#login"/>
    </do>
    </p>
    </card>

    <card id="login">


    <p align="center">
    Enter user info
    </p>
    <p align="left">
    User Name: <input name="u" title="User Name:"/><br/>
    <anchor title='Log In'>
    <go href='/cp/ps/Main/login/EnterPin?l=en&d=wmltest.cp.net' method="post">

    <postfield name="u" value="$(u)"/>
    <postfield name="rdu" value=''/>
    <postfield name="d" value='wmltest.cp.net'/>
    <postfield name="p" value='true'/>
    <postfield name="UP" value='false'/>

    <postfield name="l" value='en'/>

    <setvar name="pin" value=""/>
    </go>Log In</anchor>
    <br/>
    <anchor title='Cancel'>
    <go href="Login#login" method="post">
    <setvar name="u" value=""/>
    <postfield name="d" value='wmltest.cp.net'/>
    <postfield name="l" value='en'/>
    </go>Cancel</anchor>
    </p>
    </card>
    </wml>

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466

    RE: WML error in Nokia9210

    Hi!

    I tested your code with Nokia 9210 Communicator and found out the problem. The WAP browser in the Nokia 9210 Communicator does not accept this kind of string <do type="accept" label=" "> where the value for <do label> is empty. When the value contains text, then the page can be opened with the communicator.

    Kind regards,
    Satu/Forum Nokia Developer Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×