×

Discussion Board

Results 1 to 3 of 3

Threaded View

  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    14

    VIA header not being correctly set

    Hi,

    Recently got a Nokia E65 phone. I have VoIP working perfectly with it with a number of Sip Servers.

    I am attempting to get the E65 to register to a Lucent/Alcatel IMS. The E65 is being NAT'd router, and succesfully detects its external IP. I can see this in the Contact/SDP info in the initial Invite.

    It is however incorrectly (from what I understand of the VIA header) setting the VIA header.

    The E65s External IP & Port after NAT is:
    Z:48374

    The E65s Internal IP & Port
    10.0.69.65:5060

    Reading the RFCs - the VIA header on a Register should look like:

    Via: SIP/2.0/UDP Z:48380;rport;branch=...

    It doesn't however. Looking at the REGISTER request, it has:

    Via: SIP/2.0/UDP 10.0.69.65:5060;branch=z9hG4bK7ksvl47qi0jvnnao94mqbab;rport

    Is this correct?

    I've looked at the REGISTER requests from a couple of other phones, and they all set the Via header correctly after doing with a NAT? Or is there an option to not include the VIA option in there?


    User Datagram Protocol, Src Port: 48374 (48374), Dst Port: sip (5060)
    Session Initiation Protocol
    Request-Line: REGISTER sip:sip.X.Y SIP/2.0
    Message Header
    Via: SIP/2.0/UDP 10.0.69.65:5060;branch=z9hG4bK7ksvl47qi0jvnnao94mqbab;rport
    From: <sip:+X@sip.X.Y>;tag=k07kibbp69hc7g560dub
    To: <sip:+X@sip.X.Y>
    Contact: <sip:+X@Z:48374>;expires=3600
    CSeq: 1319 REGISTER
    Call-ID: -GJ9bu0loIcnTMdYk3e9hcQbZzQIBa
    Supported: sec-agree
    User-Agent: Nokia RM-208 1.0633.18.01
    Max-Forwards: 70
    Content-Length: 0
    sean@Sean ~ %
    Last edited by seanwg; 2007-04-22 at 14:13.

Similar Threads

  1. Create and read SMS User Data Header
    By StumpiDK in forum General Messaging
    Replies: 3
    Last Post: 2009-11-25, 08:34
  2. 302 redirection response header missing
    By morost in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-03-30, 16:24
  3. WAP upload / Content-Type header is lost at WAP gateway
    By rabai in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2004-02-24, 11:59
  4. HTTP massive header received
    By pkien168 in forum Mobile Java General
    Replies: 2
    Last Post: 2003-12-22, 06:57
  5. How to use NokiaCLMessaging.IGSMGMS interface?
    By abirnale in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2003-11-10, 14:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×