×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    12

    Carbide C++ 1.2 License Problem

    When I open Carbide, there is a prompt dialog with message:

    Carbide uses a licensing technology called FLEXnet. The FLEXnet tool has detected a problem with your license. Please contact license.carbide@nokia.com for assistance.

    Please include the following information in your email:

    1. Carbide Edition, Version, Build number (Help->About)
    2. Approximate date of purchase and registration date
    3. The license file listed below found in <install>/Carbide.c++ Licenses/
    4. A description of your problem (what was working, what is not working)
    5. The error message below

    Operation failed:
    Carbide feature: Carbide_Sys_TRK
    Carbide description: System TRK Debugging

    Invalid license file syntax.
    FLEX Feature: Carbide_Sys_TRK
    License path:
    D:\Carbide\Carbide.c++ Licenses\Current_Active_License

    FLEXnet Licensing error: -2, 413

    How to resolve it?

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Carbide C++ 1.2 License Problem

    Did you try to contact license.carbide@nokia.com with the information that the dialog asked?

    Tim

  3. #3
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    53

    Re: Carbide C++ 1.2 License Problem

    I have the same problem ! I am using Carbide c++ Express. Everytime I open the Carbide c++ ,the licence prompt dialog occur. I think it may be that I don't have the licence file.

    But how to hide the prompt dialog when carbide c++ start?

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    4

    Re: Carbide C++ 1.2 License Problem

    This is a problem in 1.2 when Express is installed. The license manager in 1.2 currently does not know if Express was installed. The license manager is being redone for 1.3, where it will know that Express is installed and be silent about features not found. At this time, there is no way to turn off this dialog.

    Chad

  5. #5
    Registered User
    Join Date
    Apr 2007
    Posts
    4

    Re: Carbide C++ 1.2 License Problem

    To Meihao,

    Is this an Express install? In an Express install, there is no license file and you should get a "Cannot find license file" error instead of "Invalid license file syntax".

    If this is an Express install, then my last post explains the problems. We hope to get a temporary fix into the 1.2.1 update and then a permanent fix into the 1.3 release (with an added feature).

    If this is not an Express install, then I need to look at your <install>/Carbide.c++ Licenses/Current_Active_License contents to determine why you are seeing the "Invalid license file syntax" error.

    Chad

  6. #6
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    53

    Smile Re: Carbide C++ 1.2 License Problem

    Thanks , Chad !

  7. #7
    Registered User
    Join Date
    Feb 2008
    Posts
    1

    Re: Carbide C++ 1.2 License Problem

    If you installed the FREE Express edition of Carbide, there is no license.

    There is a known problem with Carbide.c++ Express v1.2.0 that it displays an error message saying that there is no license. This message can be ignored.

    This problem has been fixed in v1.2.1. To install the update, run Carbide.c++ and use the menu Help >> Software Updates >> Find and Install ... Check "Search for new features to install". Install all of the updates from the Carbide.c++ Update Site.


    Thanks,
    Manar
    Egypt-CSD

Similar Threads

  1. problem when importing from carbide c++ to vs 2003!
    By misfit.physics in forum Symbian Tools & SDKs
    Replies: 12
    Last Post: 2008-02-19, 09:45
  2. Carbide C++'s UIQ 3.0 linkage problem
    By eyalmnm in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-12-21, 10:32
  3. problem in carbide
    By sameerbkamble in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-07-06, 16:48
  4. Replies: 6
    Last Post: 2006-05-30, 08:38
  5. problem with NMSS 1.2 emulator
    By lyes22 in forum General Messaging
    Replies: 0
    Last Post: 2004-03-20, 11:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •