×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    17

    OMA provisioning for WLAN problem SECMODE

    Hi all

    I am trying to configure an N91 phone for a wireless lan router. This is what I have written.

    <?xml version="1.0"?>
    <!DOCTYPE wap-provisioningdoc PUBLIC "-//WAPFORUM//DTD PROV 1.0//EN" "http://www.wapforum.org/DTD/prov.dtd">
    <wap-provisioningdoc>
    <characteristic type="NAPDEF">
    <parm name="NAPID" value="Link Router"/>
    <parm name="BEARER" value="WLAN"/>
    <parm name="NAME" value="Link Router"/>
    <parm name="INTERNET"/>
    <characteristic type="WLAN">
    <parm name="PRI-SSID" value="Link Router"/>
    <parm name="NETMODE" value="INFRA"/>
    <parm name="SECMODE" value="WPA-PRESHARED-KEY"/>
    <parm name="WPA-PRES-KEY-ASC" value="mywpakey"/>
    </characteristic>
    </characteristic>
    </wap-provisioningdoc>

    The problem is that the phone does not recognise the WPA-PRESHARED-KEY field and as a result it sets the AP as open-network. If I set SECMODE to "WPA" it sets it to WPA/WPA2 mode (which is correct) but it does not enable preshared-key mode (it enables EAP).
    Is there anyone that has found the solution to this?

    Thanks

  2. #2
    Registered User
    Join Date
    Oct 2006
    Posts
    17

    Re: OMA provisioning for WLAN problem SECMODE

    anyone? Any idea would be good. I am stuck!

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    179

    Re: OMA provisioning for WLAN problem SECMODE

    I'm having the same problem on the E61i... seems the device doesn't conform to the standard. Anyone managed to set WPA-PSK on S60 v3 devices?
    Symsource Ltd.
    [url]www.symsource.com[/url]

  4. #4
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: OMA provisioning for WLAN problem SECMODE

    Hello,

    I had that kind of problem on the E61 & E70 devices (I do not remember the sw version) reason was the firmware problem, so u need to try to update your device. Maybe that is solution also for your case.

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    179

    Re: OMA provisioning for WLAN problem SECMODE

    No, its the latest firmware....
    Symsource Ltd.
    [url]www.symsource.com[/url]

  6. #6
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: OMA provisioning for WLAN problem SECMODE

    What is your sw version, I will check if I found some more info.


    -tum-

  7. #7
    Nokia Developer Expert
    Join Date
    Dec 2006
    Location
    Mountain View, CA
    Posts
    197

    Re: OMA provisioning for WLAN problem SECMODE

    Nokia WLAN team tested this XML code and seemed to work without any problems. Please always have your phone running with the latest sw release.

    You can update your phone's firmware using Nokia Software Updater.

  8. #8
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: OMA provisioning for WLAN problem SECMODE

    Hello!

    Does the team tested it with the latest software, or the software which can be found form service center or using software updater?

    -tum-

  9. #9
    Nokia Developer Expert
    Join Date
    Dec 2006
    Location
    Mountain View, CA
    Posts
    197

    Re: OMA provisioning for WLAN problem SECMODE

    It appeared that R&D tested with S60 3.2 software and with a device that has yet not even been announced.

    Please post the model of your phone and sw image version, let's us try it again with the phones & firmware versions that you have. You can get the sw version by typing *#0000#.

  10. #10
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    179

    Re: OMA provisioning for WLAN problem SECMODE

    The E61i I tried this on is 1.0633.62.05 15-02-07 (yes, that is the latest firmware for a Vodafone E61i according to Nokia SW updater).

    However, it would be real nice if Nokia could tell us what devices it *does* work on - I'm trying to develop a management solution here, not just set up one test device.....
    Symsource Ltd.
    [url]www.symsource.com[/url]

  11. #11
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: OMA provisioning for WLAN problem SECMODE

    Hello,

    almost only way to do it is us set SECMODE to "WPA", but if I understand correctly, it's not acceptable on your case.

    It's also little bit hard to say for customers, that if you have that and that device, you should also be the latest software, otherwise it doesn't work.

    -tum-

  12. #12
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    179

    Re: OMA provisioning for WLAN problem SECMODE

    So, am I right in saying the conclusion is "it doesn't work" - i.e. its a bug?
    Clearly doesn't work on this E61i, with latest firmware, and if Nokia can't confirm what it does and doesn't work on, there is little point developing OMA CP solutions.
    Symsource Ltd.
    [url]www.symsource.com[/url]

  13. #13
    Nokia Developer Expert
    Join Date
    Nov 2007
    Posts
    5

    Re: OMA provisioning for WLAN problem SECMODE

    Hi KevinD,

    I checked some software releases for S60 3rd ed. for example for E60 and E70 and there was a bug that caused the security mode to be left open in case it should be WPA-PSK. This was however corrected pretty soon and for example E60 SW 3.0633.09.04 dated 20-11-06 works okay with thefrozenrose's settings.

    I also checked E61i SW version 1.0633.62.05 dated 15-02-07 source code and it does include the fix to the above problem. So the problem you are having is probably something else. Unfortunately I don't have E61i currently in my hands so I cannot test.

    Are the symptoms how it does not work in your case similar as in thefrozenrose's original message? So that the security mode is open even if you send the settings with PSK?

  14. #14
    Nokia Developer Expert
    Join Date
    Nov 2007
    Posts
    5

    Re: OMA provisioning for WLAN problem SECMODE

    Hi,

    Some more information to this:

    I now got the E61i to my hands with SW version 1.0633.62.05 15-02-07 (RM-227 Nokia E61i-1).

    I sent the thefrozenrose's settings exactly as they are to the phone. Access point "Link Router" was created with the security mode set as WPA/WPA2 and WPA/WPA2 mode set to Pre-shared key. So at least this scenario seems to work.

Similar Threads

  1. OMA Sip client provisioning
    By wes_jin in forum OMA DM/DS/CP
    Replies: 0
    Last Post: 2006-11-08, 04:28
  2. Provisioning gprs settings for j2me application via OMA DM?
    By bit5@mail.ru in forum OMA DM/DS/CP
    Replies: 0
    Last Post: 2006-09-25, 05:55
  3. OMA Provisioning with PROXY Setting
    By shadowz in forum OMA DM/DS/CP
    Replies: 4
    Last Post: 2004-07-28, 23:19
  4. setting bookmarks using OMA provisioning
    By seancronin in forum OMA DM/DS/CP
    Replies: 1
    Last Post: 2003-12-24, 00:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •