×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    105

    keys simulation not working.

    Hi,
    i am try to simulationg the Defeaultphoney keys, priviously i simulated LeftSoftkey and RightSoftKey of the Phone Window Group its working fine.

    Now i am try to simulate the valumeInckey and volumedecKey ut noe its not woking.

    i am using this code.

    TInt CAppUi::HandleVolumeControls(TInt aKey)
    {

    RWsSession sess=CCoeEnv::Static()->WsSession();
    TWsEvent event;
    TInt id=sess.FindWindowGroupIdentifier( 0, _L("*Phone*") );
    event.SetType(EEventKey);
    event.SetTimeNow();
    if(aKey == EKeyLeftArrow)
    {
    event.Key()->iCode = EKeyDecVolume;//EKeyLeftArrow; i tried this one also

    if(iLoudSpeakerVolume > 1)
    {
    iLoudSpeakerVolume--;
    }
    else
    {
    iLoudSpeakerVolume = 1;
    }
    }
    else if(aKey == EKeyRightArrow)
    {
    event.Key()->iCode = EKeyIncVolume;//EKeyRightArrow;//EKeyDevice0;//EKeyCBA1;

    if(iLoudSpeakerVolume>=10)
    {
    iLoudSpeakerVolume = 10;
    }
    else
    {
    iLoudSpeakerVolume++;
    }
    }
    event.Key()->iModifiers = 0;
    event.Key()->iRepeats = 0;
    event.Key()->iScanCode = EStdKeyNull;
    sess.SendEventToWindowGroup( id, event );

    return iLoudSpeakerVolume;

    }

  2. #2
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: keys simulation not working.

    on which device your testing it?
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  3. #3
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    105

    Re: keys simulation not working.

    hi krish,
    i am using 3rd edition E61 Device.

Similar Threads

  1. New N70 bought but some keys are not working
    By bgawde in forum General Development Questions
    Replies: 0
    Last Post: 2006-12-22, 19:34
  2. ProgresBar Active No other Keys are not Working.
    By sriramadasu in forum Symbian
    Replies: 3
    Last Post: 2006-12-08, 11:06
  3. S60 Emulator Keys (some) not working
    By mfaraon in forum Mobile Java Tools & SDKs
    Replies: 6
    Last Post: 2006-10-28, 22:52
  4. My soft Keys of Nokia 6600 are not working for my application
    By ummarbhutta in forum Mobile Java General
    Replies: 6
    Last Post: 2006-03-27, 22:16
  5. soft keys not working in 3650 for FullCanvas
    By chandanp in forum Mobile Java General
    Replies: 0
    Last Post: 2002-11-06, 09:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×