×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Question KErrNotSupported when loading DLL on target

    Hi,

    I have a problem where the DLL I'm converting from 2nd ed to 3rd ed will run OK on the emulator but fails to load with -5 (KErrNotSupported) when run on the target device (N73). A test stub version will load and run but not the full version. Any ideas where its going wrong.

    The DLL has its own UI resources and needs to read and write files. It also makes a HTTP connection but this code is only activated during operation, not on load.

  2. #2
    Super Contributor
    Join Date
    May 2005
    Location
    Hyderabad,India
    Posts
    704

    Re: KErrNotSupported when loading DLL on target

    Hi,

    Have u placed ur dll in \sys\bin\ folder?

    regards,
    eswar

  3. #3
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Re: KErrNotSupported when loading DLL on target

    Yes, the stub version works fine so I know its being installed to the right directory (I use the same .pkg file to generate the sis).

  4. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Angry Re: KErrNotSupported when loading DLL on target

    It now looks like the problem was that I used charconv in my DLL which needs to be handled differently in 3rd ed. What a pity it did not show up on the emulator!

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. [newbie here] Link error
    By xitpu in forum Symbian
    Replies: 3
    Last Post: 2007-01-24, 16:53
  3. DLL loading: KErrCorrupt
    By samuel.weibel@ascom.ch in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2007-01-09, 08:00
  4. Replies: 0
    Last Post: 2003-04-27, 21:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×