×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Feb 2007
    Posts
    125

    Question recording work on emulator but not on phone?!

    hi everybody!

    i used recording audio in pcm format ( i saw the audio streaming example ).

    my program works fine on the emulator but don't begin recording using the phone!

    i used UserEnvironment capability but i don't have any result!

    should i use amr format instead of pcm?

    what should i do to make my program work on the phone?

    please, help!
    Last edited by noussaENSI; 2007-05-02 at 10:21.

  2. #2
    Regular Contributor
    Join Date
    May 2005
    Location
    Sweden
    Posts
    272

    Re: recording work on emulator but not on phone?!

    First I suggest you try debugging the problem. If that doesn't solve it, post a question including relevant information. For this sort of problem, the absolute minimum of information you need to post is the phone model. You should also include a short description of what you've tried so far, what happened etc.
    Mobile Sputnik: http://ptrmobile.blogspot.com/

  3. #3
    Regular Contributor
    Join Date
    Feb 2007
    Posts
    125

    Question Re: recording work on emulator but not on phone?!

    in my application, i used recording and reading data using MdaAudioInputStream.h and MdaAudioOutputStream.h ( as in the audio stream example) but i added another view where i tried to show a progressing note for recording and playing (as in the recorder example).

    in the emulator it works fine: meaning that it records audio data and i can play it (with drawing the pregressing note) it's exactly what i want!

    but using the phone (N80 or N93) nothing is recorded (no pregression in the progression note and no voice heared when pressing play!)

    what is the difference between recording on teh phone and on the emulator?

    can you help me, please!

  4. #4
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    75

    Re: recording work on emulator but not on phone?!

    Hi All,

    Even i Have same problem. can any one have a look at audio recording and playback streaming example in forum nokia . It is given in documentation -> multimedia (towards left side). It works fine on the emulator and i have done all the necessary things suggested in the release notes of it.



    BR,
    Saritha

  5. #5
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    75

    Re: recording work on emulator but not on phone?!

    Hi ,

    Its working fine on the phone but with low volume thats y i couldnt notice. Make all necessary settings that are suggested in the release notes of it.

    BR,
    Saritha

Similar Threads

  1. CMdaAudioToneUtility play does not work during phone call
    By binli120 in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-01-03, 08:57
  2. MIDlet will not work on phone 6100
    By Woody_FX in forum Mobile Java General
    Replies: 2
    Last Post: 2003-10-31, 14:36
  3. Does not work in the phone
    By AndayaL in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-08-12, 09:43
  4. Replies: 1
    Last Post: 2002-07-23, 06:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×