×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Registered User
    Join Date
    May 2007
    Posts
    9

    S60 3rd FP1 emulator not working

    Hi,

    I've installed the following:

    - Windows Vista Business
    - Sun JDK 1.6.0_01 and JRE 1.6.0_01
    - nS60_jme_sdk_3rd_e_FP1 installed into C:\S60

    I am trying to follow the "Example: Creating an application from the command line interface" chapter in the Getting Started document. Compilation and preverification work fine, but when I run the midlet in the emulator, the emulator displays an Unhandled exception. The emulator shows the following before the exception:

    [...]
    Installation complete
    Reading Start MIDlet request
    Starting MIDlet
    Please wait...

    Even though I click Yes to close the application, HelloWorldPlusMIDlet still shows in the Task Manager in Diagnostics. Starting it from Menu/Installed shows an empty screen.

    Some questions:

    1. How should I see the information about the Unhandled exception? SystemOut in Diagnostics shows nothing.

    2. Any idea why the Unhandled exception happens (probably easy to answer if I can get the info from question 1 above).

    3. How can I reset the emulator to remove everything I've installed and start with "factory settings"? I wouldn't like uninstall/reinstall the whole SDK...

    Thanks for any input!

  2. #2
    Registered User
    Join Date
    May 2007
    Posts
    1

    Re: S60 3rd FP1 emulator not working

    Hi mnoromaa!

    You may need to install JRME 1.4.x. and configure Carbide to use it instead of 1.6.x! May be your problem is just the same i got when starting to develop Java MIDlets some time ago:
    java.lang.Error: ClassFormatError: Invalid version in .class file
    (look at the Carbide.j output or Eclipse Carbide.j Console)

    And this issue apears to be nowhere at the official documentation nor at Forum Nokia Doc (I found this at http://discussion.forum.nokia.com/fo...ad.php?t=84419 )

    Try this and post again!

    Edwin Isea A.

  3. #3
    Registered User
    Join Date
    May 2007
    Posts
    9

    Re: S60 3rd FP1 emulator not working

    Thanks for your reply! My problem appeared without Carbide.j, although I tried to install it too (and failed).

    I thought that the command-line build process should be the simplest possible way of building and running S60 apps, so I thought I should get that working before trying any IDE tools... Still not working.

  4. #4
    Registered User
    Join Date
    May 2007
    Posts
    9

    Re: S60 3rd FP1 emulator not working

    By the way, I tried the "-target 1.4" and "-target 1.5" options with javac, but they didn't help. I think the "Invalid version in .class file" could easily be the problem in my case as well.

    But how on earth can I see the actual exception??? Do I need to attach a debugger? I've tried looking at jdb options, but all I can say at this point is that it's not trivial...

    I'm going to try installing an older JDK release next. Can anyone tell if I should install 1.4 or 1.5 (5.0)?

  5. #5
    Registered User
    Join Date
    May 2007
    Posts
    9

    Re: S60 3rd FP1 emulator not working

    OK, I retried on a new computer with the following config:

    - WinXP Pro SP2
    - JDK 1.5.0_04

    Following the basic command-line procedure to build HelloWorldPlusMIDlet, I still get an Unhandled exception when the midlet first starts! It works exactly the same way as described in my original post.

    I am clueless now. I thought that Vista + new JDK could account for the problems, but XP + old JDK has the same problem?!?! What else can I try? Is the S60 SDK broken?

  6. #6
    Registered User
    Join Date
    May 2007
    Posts
    20

    Re: S60 3rd FP1 emulator not working

    I seem to be running into the same problem. Did you ever find a solution?

    Will

  7. #7
    Registered User
    Join Date
    Mar 2004
    Posts
    1

    Re: S60 3rd FP1 emulator not working

    Quote Originally Posted by will@premierobjects.com
    I seem to be running into the same problem. Did you ever find a solution?

    Will
    The problem is here too. I have tested also with JRE 1.4.2_15 but still getting the "unhandled exception" when emulator has started.

    Edit: My computer is running on Win XP and I'm using Eclipse 3.1.
    Last edited by mhurmeri; 2007-07-03 at 17:39.

  8. #8
    Registered User
    Join Date
    Jul 2007
    Posts
    1

    Re: S60 3rd FP1 emulator not working

    i have too problem :/ i have tested with jdk-1_5_0_12 and netbeans 5.5.1 with mobility pack in win xp sp2, and i getting the "unhandled exception" when emulator has started..

    somebody already found the solution?

  9. #9
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: S60 3rd FP1 emulator not working

    Hi,
    This may be useful, but I have Netbeans 5.1, running under Win XP and Vista!, both use the version version 6 (1.601) now 6 . 2

    http://www.java.com/en/download/
    I use the windows online configure.

    Jim

  10. #10
    Registered User
    Join Date
    Jul 2007
    Posts
    2

    Re: S60 3rd FP1 emulator not working

    Hi,

    I installed today the SDK, and have experienced the same problem. I'm running WIN XP SP2, and tried compiling the demo application from the command prompt both with Java 1.4.2_09 and 1.5.0_04.

    Given that this problem has been reported already two month ago, I'm not really impressed with the stability of the development environment, and the reaction time of the Nokia support....

    Heiko

  11. #11
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: S60 3rd FP1 emulator not working

    hi,
    Login as "Administrator"
    or in Vista Right Click "Run as Administrator"

    The PATH for XP should be
    [QUOTE]
    PATH=C:\Program Files\Common Files\Symbian\Tools;
    C:\Program Files\PC Connectivity Solution\;
    C:\Perl\bin\;
    C:\Program Files\Nokia\Carbide.c++ v1.2_3\x86Build\Symbian_Tools\Command_Line_Tools;
    C:\Program Files\CSL Arm Toolchain\bin;
    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;
    C:\Program Files\Java\jdk1.5.0_05\bin;[/QUOTE]


    the highlighted bits are most important
    see http://wiki.forum.nokia.com/index.ph...Vista_%28tm%29


    Jim

  12. #12
    Registered User
    Join Date
    Jul 2007
    Posts
    2

    Re: S60 3rd FP1 emulator not working

    Hi Jim,

    thanks for your effort ! But:
    - I am running Win XP, not Vista
    - I have only installed the SDK, so I haven't got any of the "PC Connectivity Solution", "Perl", "Command_Line_Tools" or "CSL Arm Toolchain" directories on my system.

    Best regards

    Heiko

  13. #13
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: S60 3rd FP1 emulator not working

    Are you just using part of the code for Java?.


    Good Luck
    Jim

  14. #14
    Registered User
    Join Date
    Aug 2007
    Posts
    1

    Re: S60 3rd FP1 emulator not working

    Hi,

    Have any of you found and fixed this problem? It happened to me too when I tried to run the example HelloWorld MIDlet. Most times I got "Unhandled Exception. Close Application?" on the emulator screen but some times I get a warning window as well:

    Symbian SDK error
    Caught exception:
    java.lang.runtimeexception:command failed with Symbian code error -10501
    at ...SessionCommand.load
    at ...InstallCommand.load
    .
    .
    .

    I am using Eclipse 3.30 with carbide.j, Windows XP, Java 6, and S60 3rd FP1 SDK. I have tried with several other example Midlets and got the same problem too. Meanwhile I'll spend more time on this and will post solutions for any progress.

    Thanks

  15. #15
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: S60 3rd FP1 emulator not working

    Hi,

    Try using an older version of Eclipse (3.1.2) for example, it might work fine.

    Br,
    Juarez Alvares Barbosa Junior - Brazil

Similar Threads

  1. Extra E90 screen size in the S60 3rd edition FP1 emulator
    By svdwal in forum Symbian Tools & SDKs
    Replies: 34
    Last Post: 2009-05-12, 08:55
  2. SyncML API and S60 3rd edition?
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2008-03-20, 14:50
  3. S60 3rd Ed FP1 Emulator Error
    By napperley in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2007-04-03, 01:04
  4. Hotkey support in S60 3rd ed FP1
    By svdwal in forum Symbian User Interface
    Replies: 0
    Last Post: 2007-02-12, 12:09
  5. RWsSession in S60 3rd ed FP1
    By newnb in forum Symbian
    Replies: 4
    Last Post: 2007-01-26, 02:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×