×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    KErrNotSupported when running the example in Audio Policy Server 2.3

    Hi,
    I install the AudioProxyServer23Test example in my phone and run it. After initialize the device and try to start streaming, I am getting an error "output device initialization error-> 11", does anyone encouter the same problem or have successfully run the application?

    Thanks!

  2. #2
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Hi again,
    When I add the streamerengine.cpp and queuehandler.cpp to my application and run it from my application by first calling InitializeL(), NotifyError() is returned with error code -5 (KErrNotSupported). Does anyone know what is the problem here?

    Thanks!

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Can you tell which phone model you are trying? Any additional info about your environement will help also!

  4. #4
    Registered User
    Join Date
    May 2007
    Posts
    8

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    I have the exact same error. Were you able to resolve this? I am running it on E61. I would appreciate any help!

  5. #5
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    I found the answer. You have to install the APS sis file that comes with the package, then install the test app sis.

  6. #6
    Registered User
    Join Date
    May 2007
    Posts
    8

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Hmm.. I have the apssession2.sisx installed - i wonder what else is wrong..

  7. #7
    Registered User
    Join Date
    May 2007
    Posts
    8

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Can you please tell me the SDK and the extensions versions you are using? I am still having the issue.. -thanks!

  8. #8
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    I am using sdk release 9.1 and APS 2.31 and I run it on Nokia E61.

  9. #9
    Registered User
    Join Date
    Sep 2006
    Posts
    4

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Hi,

    did you guys come to a conclusion in this question?

    I'm having the same problem (Output Stream Initialized -> -5 (KErrNotSupported)) when using the classes CStreamerEngine, MQueueHandlerObserver and CQueueHandler (from example AudioProxyServer_v2.31).

    If I use the streamer.sis (included in example) the loopback works, so the server-part works.

    I have tried many settings on Players iChannels and iSampleRate since the settings in example refers to file sounddevice.h that doesn exist in my sdk.

    I'm using:
    device: 6290
    sdk:S60_3rd_FP1

    Anyone got ideas?

  10. #10
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    There are two SDK plug-ins, one for 3rd edition and one for 3rd edition FP 1. I think that was the original problem for the first person. Let make sure this is not your problem. If not, the we can discuss this further.

    See details here: http://wiki.forum.nokia.com/index.php/SDK_API_Plugin

  11. #11
    Regular Contributor
    Join Date
    Dec 2006
    Posts
    59

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Hi!

    I'm having the same issue, I'm using the plugin "S60_3rd_SDK_MR_API_Plug-In_Pack_v5.zip" which I guess is the right one for my devices (E60 & E70, 3rd edition without fp1).

    I tried the APS loopback example on the E60 device, there everything works fine. But when I use streamerengine.cpp and queuehandler.cpp in my application, InitializePlayer() returns with Output device initialization error -11 on both devices E60 and E70.

    Did anyone resolve this?? Any clue?
    What could possibly be the reason for InitializePlayer() to return with -11?
    Changing the settings the device gets initialized with doesn't have any effect, some problem with the UID maybe????

    I really got stuck here, plaese help!!!!
    Last edited by bifihi; 2007-12-20 at 19:07.

  12. #12
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Have you checked the APS wiki page? There are description there regarding initialization. The page is here

    By the way, your error:
    KErrAlreadyExists -11 Already exists
    Have you done something twice?

  13. #13
    Regular Contributor
    Join Date
    Dec 2006
    Posts
    59

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    Thanks for the reply. I checked the Wiki, and I'm also pretty sure I didn't do anything twice.

    In fact I just copied the two files (StreamerEngine.cpp and QueueHandler.cpp) from the example, and I call InitializeL() and StartLoopback() from another class.
    I didn't make any changes in the example code yet (except for deleting some GUI logging).

    In the rest of my application there is no code related to the sound devices or similar. So I really wonder what InitializePlayer() collides with.......
    Last edited by bifihi; 2007-12-22 at 21:18.

  14. #14
    Regular Contributor
    Join Date
    Dec 2006
    Posts
    59

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    I still couldn't figure out what the problem is.
    Doesn't anyone have an idea??

    Any clues would be highly appreciated!
    Could it be an UID issue?

    Merry christmas and happy new year by the way!

  15. #15
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: KErrNotSupported when running the example in Audio Policy Server 2.3

    The fact that you have the example running with no problem is good.

    You are probably on the right track about the UID.

    Do you always play the example first, then try your own application? I wonder if you are setting the iPsetting to the same UID? While you have started the example already?

    iPSettings.iGlobal = _L("2000521C"); // use your app UID

Similar Threads

  1. Web Server running on phone/PDA
    By David T. McKee in forum Mobile Java General
    Replies: 8
    Last Post: 2004-08-17, 15:42
  2. Running a MMS Server
    By saturim in forum General Messaging
    Replies: 1
    Last Post: 2003-10-01, 18:11
  3. Replies: 1
    Last Post: 2003-09-08, 12:58
  4. Nokia Activ Server 2.1 - problems
    By choumanb in forum WAP Servers
    Replies: 0
    Last Post: 2003-05-16, 07:34
  5. Errors trying to connect to server running SSL ( 443 )
    By Nokia_Archive in forum WAP Servers
    Replies: 1
    Last Post: 2002-05-16, 18:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×