×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    9

    Try to ODD app, get Symbian err -10509

    First, in the interest of full disclosure I should say that I'm using Eclipse v3.1.2, CarbideJ1.5, JavaSE1.5.0_11, S60 SDK 3rd Ed. FP1 and a Nokia E62 phone.

    I'm trying to debug my app (actually right now I'm using the FileHandler example). I've gotten it running on the S60 emulator. When I first got the app to download to the phone I got an unhandled Security exception. So I researched that and decided that I needed to set that the midlet needed file read & write permissions in the .jad and the manifest. Now when I attempt to debug on the E62 I get a RuntimeException: command failed with Symbian error code: -10509. From the searching that I've done, this appears to be that I'm trying to load an untrusted app which uses trusted api's.

    Is it necessary to sign an app to debug it on the device? If so, why doesn't the documentation make this explicit. I'm not getting the popup dialog box (which is documented) asking me if I want to allow the app to access the file system, it's not being allowed to load on to the device. None of the places that I've found in the documentation that talk about debugging on the phone say that you (may) need to sign an application even when using the debugger.

    I also have to second the comment by Tzurs in this thread: http://discussion.forum.nokia.com/fo...ighlight=10509 that this development environment is extremely frustrating. Pieces of what you need to know are scattered around in many different places, sometimes with links, sometimes not. Some important information isn't in the Nokia documentation at all, but referenced in discussion board threads to outside websites. Some of the documentation appears to be just plain wrong, until I figure out that it's referring to an old piece of software that has been replaced, but the documentation hasn't been updated. And then, at least for my environment (the E62), the new replacement doesn't work, and it's necessary to use the older version of the software (Debug_Agent_for_S60_Java.SIS).

    Guess I'll have to do some research into signing my app, any pointers as to whether this is my problem would be greatly appreciated.

    Thanks in advance,

    Greg

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Try to ODD app, get Symbian err -10509

    Greg,

    I have already asked this on another thread, but it looks like you do have a AT&T/Cingular device, in which case you should check here http://blogs.forum.nokia.com/view_entry.html?id=360

    Hartti

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    1

    Re: Try to ODD app, get Symbian err -10509

    I was getting this error because I tried to include classes in javax.* packages in my app. Once I renamed the packages to org...javax.*, the app loaded successfully. I was using an emulator (S60-3 original), not an actual phone, and I set preferences to "Allow" all permissions for all midlets, so apparently it doesn't like javax in midlets at a very basic level.

    Apparently other people also ran into the same error when they imported internal/unsupported classes, so search all your sources for 'import com', like so in a Cygwin shell:

    find . -name \*.java -exec grep '^import com' {} \; -print

    and try to temporarily remove them one by one...

Similar Threads

  1. newbie: Adding controls to Symbian app
    By Audun Holme in forum Symbian
    Replies: 2
    Last Post: 2006-06-04, 13:42
  2. j2se app -> symbian c++ using cyberabi
    By kerfunkledbongle in forum Bluetooth Technology
    Replies: 0
    Last Post: 2006-04-24, 18:48
  3. Replies: 2
    Last Post: 2004-05-08, 09:09
  4. Replies: 0
    Last Post: 2004-05-07, 11:45
  5. Communication with native Symbian app on Nokia 7650
    By LiamQ in forum Mobile Java General
    Replies: 1
    Last Post: 2002-08-01, 12:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×