×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    6310 and Accesskey

    Hi,

    I'm trying to use the accesskey attribute to enable link navigation with the keypad - but I just can't seem to get it to work on a real device.

    My test code is as follows:

    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.3//EN"
    "http://www.wapforum.org/DTD/wml13.dtd">

    <wml>
    <card id="Zip" title="Ricochet">
    <p>
    <a href="new.wml" accesskey="5">Press 5</a>
    </p>
    </card>
    </wml>


    I've tried pressing "5" briefly, and holding it down 1, 2, 3, 4, 5, up to 10 seconds - and nothing happens whatsoever.

    I've found a few other examples in the knowledge base of people having this problem, and there have been some snippets of code posted - but no example of a complete WML file.

    Please, could someone post a working example of a complete file, including the DTD, etc.

    I am testing on a 6310i, and I think my Telco uses an Openwave 5 gateway.


    Thanks,

    - Daniel

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466

    RE: 6310 and Accesskey

    Hello!

    Here is a simple WML code with accesskey element. This should work. In case not, please let us know.

    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.3//EN"
    "http://www.wapforum.org/DTD/wml13.dtd">
    <wml>
    <template>
    <do type="prev"><prev/></do>
    </template>
    <card id="card1" title="Card #1">
    <do type="unknown" label="Next">
    <go href="#card2"/>
    </do>
    <p align="center">
    <a accesskey="2" href="page2.wml">2. Second page,please </a>
    </p>
    </card>
    </wml>

    Kind regards,
    Satu/Forum Nokia Developer Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •