×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    105

    E61 Default Input Mode Not Working

    hi all,
    I implemeted in my Application for entering mobile number i written in rss file like below.But it always shown alphabitcal characters at that time i need to change the mode of entry, without changing mode of entry is it possible to enter numbers.I am using series60 3rd edition for E61 mobile.In this by default mode entry i given number it's not working.But same worrking in 2nd edition mobiles.

    RESOURCE DIALOG r_dialog_done_cancel
    {
    flags = EGeneralQueryFlags;
    buttons = R_AVKON_SOFTKEYS_DONE_CANCEL;
    items =
    {
    DLG_LINE
    {
    type = EAknCtQuery;
    id = EGeneralQuery;
    control = AVKON_DATA_QUERY
    {
    layout = EDataLayout;
    label = telnumber_label;
    control = EDWIN
    {
    flags = EEikEdwinNoHorizScrolling | EEikEdwinResizable;
    default_input_mode = EAknEditorNumericInputMode;
    allowed_input_modes = EAknEditorNumericInputMode;
    width = edwin_item_width;
    lines = edwin_item_lines;
    maxlength = user_name_max_length;
    };
    };
    }
    };
    }

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: E61 Default Input Mode Not Working

    Quote Originally Posted by pistha
    hi all,
    I implemeted in my Application for entering mobile number i written in rss file like below.But it always shown alphabitcal characters at that time i need to change the mode of entry, without changing mode of entry is it possible to enter numbers.I am using series60 3rd edition for E61 mobile.In this by default mode entry i given number it's not working.But same worrking in 2nd edition mobiles.
    Hi pistha,

    try to this function for default input mode.
    SetAknEditorInputMode(EAknEditorNumericInputMode);

    or
    SetDefaultInputMode(EAknEditorNumericInputMode);

    hope it'll help you.

  3. #3
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    105

    Re: E61 Default Input Mode Not Working

    I try this method but still it 's not working.

    SetDefaultInputMode(EAknEditorNumericInputMode);

  4. #4
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: E61 Default Input Mode Not Working

    Quote Originally Posted by pistha
    hi all,
    I implemeted in my Application for entering mobile number i written in rss file like below.But it always shown alphabitcal characters at that time i need to change the mode of entry, without changing mode of entry is it possible to enter numbers.I am using series60 3rd edition for E61 mobile.In this by default mode entry i given number it's not working.But same worrking in 2nd edition mobiles.

    RESOURCE DIALOG r_dialog_done_cancel
    {
    flags = EGeneralQueryFlags;
    buttons = R_AVKON_SOFTKEYS_DONE_CANCEL;
    items =
    {
    DLG_LINE
    {
    type = EAknCtQuery;
    id = EGeneralQuery;
    control = AVKON_DATA_QUERY
    {
    layout = EDataLayout;
    label = telnumber_label;
    control = EDWIN
    {
    flags = EEikEdwinNoHorizScrolling | EEikEdwinResizable;
    default_input_mode = EAknEditorNumericInputMode;
    allowed_input_modes = EAknEditorNumericInputMode;
    width = edwin_item_width;
    lines = edwin_item_lines;
    maxlength = user_name_max_length;
    };
    };
    }
    };
    }
    Hi pistha,

    try this code, for your rss file, I am sure It'll work for you.

    RESOURCE DIALOG r_dialog_done_cancel
    {
    flags = EGeneralQueryFlags;
    buttons = R_AVKON_SOFTKEYS_DONE_CANCEL;
    items =
    {
    DLG_LINE
    {
    type = EAknCtQuery;
    id = EGeneralQuery;
    control = AVKON_DATA_QUERY
    {
    layout = EPhoneLayout;
    label = telnumber_label;
    control = EDWIN
    {
    width = edwin_item_width;
    lines = edwin_item_lines;
    maxlength = user_name_max_length;
    };
    };
    }
    };
    }

    Have a nice day..!
    No gain without pain...!

  5. #5
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    105

    E61 Default Input Mode Not Working

    Thanks it's working fine.

  6. #6
    Registered User
    Join Date
    May 2007
    Posts
    22

    Unhappy Re: E61 Default Input Mode Not Working

    I am also having similar kind of problem, I want to display a secret dialog with default numeric mode. I am using the following code on E61, but it's not working:

    rss file:

    RESOURCE DIALOG r_data_query_password
    {
    flags = EAknGeneralQueryFlags;
    buttons = R_AVKON_SOFTKEYS_OK_CANCEL;
    items =
    {
    DLG_LINE
    {
    type = EAknCtQuery;
    id = EMobileAssistantConferenceControlViewSecret1;
    control = AVKON_DATA_QUERY
    {
    layout = ECodeLayout;
    label = STR_MobileAssistantConferenceControlView_34;
    control = SECRETED
    {
    num_letters = 9;
    };
    };
    }
    };
    }

    in cpp file

    TInt CPasscodeTestContainerView::RunDataQueryPasswordL(TDes& aData,
    TBool aUseDefaults, const TDesC* aOverridePrompt)
    {
    if ( aUseDefaults)
    {

    }

    CAknTextQueryDialog* queryDialog = CAknTextQueryDialog::NewL ( aData);

    if ( aOverridePrompt != NULL)
    {
    CleanupStack::PushL ( queryDialog);
    queryDialog->SetPromptL ( *aOverridePrompt);
    CleanupStack::Pop (); // queryDialog
    }
    queryDialog->PrepareLC (R_DATA_QUERY_PASSWORD);
    queryDialog->SetDefaultInputMode (EAknEditorNumericInputMode);
    return queryDialog->RunLD ();
    }

    It's working fine on emulator but on E61 it always shows, alpha keymap.

  7. #7
    Regular Contributor
    Join Date
    Jun 2007
    Location
    INDIA
    Posts
    73

    Re: E61 Default Input Mode Not Working

    Hi,

    'EPhoneLayout' takes only phone number.

    But I have ab issue:

    I am using Rich text editor, so that I can have both text and numeric input as and when required (User can change the mode based on special keys present on the phone).

    I want to set Numeric as default mode.
    Setting 'default_input_mode = EAknEditorNumericInputMode' in the resource definition works fine on E65/N80, but its not working on E61i. The default mode set to Alphabet.

    Do I need to do any additional setting for this.

    Thanks in advance

  8. #8
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    179

    Re: E61 Default Input Mode Not Working

    Default input mode doesn't work on QWERTY devices:
    http://wiki.forum.nokia.com/index.ph...keypad_devices
    Symsource Ltd.
    [url]www.symsource.com[/url]

Similar Threads

  1. Defaulting to numeric input mode on 7710
    By asy@hostnest.net in forum Symbian User Interface
    Replies: 0
    Last Post: 2005-06-25, 08:33
  2. Replies: 9
    Last Post: 2005-04-28, 14:28
  3. Replies: 0
    Last Post: 2004-03-12, 09:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×