×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2005
    Posts
    2

    Unhappy I got problem to work with carbide.vs

    Dear Sir,

    I got problem to work with carbide. I don't know why doesn't seperate mmp file when import bld.inf to create symbian os project.

    // in bld file
    PRJ_MMPFILES
    #ifdef EKA2
    3rd_ed.mmp
    #else
    2nd_ed.mmp
    #endif

    // in ccp file
    #ifdef __SERIES60_30__
    const TInt numSCAddresses = serviceSettings.ServiceCenterCount(); --(1)
    #else
    const TInt numSCAddresses = serviceSettings.NumSCAddresses(); --(2)
    #endif

    In the code above, when i try to build solution. It call both of (1) and (2). In my opinion, it call (1) if EKA2 and call (2) if not EKA2. Is possible carbide doesn't work to combine symbian 8 and 9?

    Regards,
    Nannapat W.

  2. #2
    Registered User
    Join Date
    Feb 2004
    Posts
    1,980

    Re: I got problem to work with carbide.vs

    Carbide.vs doesn't support marco EAK2 during the preprocessing of .inf files,it only supports the macro _CARBIDE_CPP_ .So Carbide.vs can't select correct .mmp file base on default SDK automaticly.You'd better import 2nd or 3rd edition .mmp file directly when you build 2nd or 3rd edition target.

  3. #3
    Registered User
    Join Date
    Feb 2004
    Posts
    1,980

    Re: I got problem to work with carbide.vs

    Sorry!
    And the marco __SERIES60_30__ is supported in .cpp.

Similar Threads

  1. Problem MMC+USB Connection
    By Fede81 in forum Symbian
    Replies: 1
    Last Post: 2007-06-14, 06:13
  2. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. What is the real problem to receive data calls with Nokia TDMA cel modems?
    By jackal_jr in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-12-09, 09:02
  5. PJava runtime problem within Nokia 9210, Hrlp~!
    By Nokia_Archive in forum PersonalJava
    Replies: 1
    Last Post: 2002-05-28, 13:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×