Hi All,

I bought the "Symbian OS C++ For Mobile Phones" book and I installed the Metrowerks IDE and also the UIQ (SDK 2.0 Candidate 2) from the CD.

Since Metrowerks IDE said it will expire in just 15 days, and since Carbide is recommended I downloaded Carbide.c++ IDE and installed it.

Then I started Carbide and tried creating a new project "Symbian C++ Project" but it says "There are no matching SDKs installed".

I then went to Window->Preferences and went to "SDK Preference". And in that I saw "UIQ 70" listed 2 times in red with a message below saying:

EPOCROOT: C:\symbian\UIQ_70
OS Version: cannot be determined
Available Platforms: Platforms cannot be determined
Diagnostic Check: SDK cannot be used in Carbide. Make sure your EPOCROOT is valid and the OS version is properly set.

Do I have to remove the UIQ_70 I Installed from the CD and download and install a new one?? All this about SDKs is a bit confusing.

Can anyone tell me how to fix this so I can get my first Symbian C++ project running?