×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    17

    Application does not appear after installation

    Hi there,

    I have a problem. I am trying to deploy an application in a N91 using SDK_S60_FP1, compiled with GCCE. It installs correctly but I cant find my application icon in the menu. I read about the UID issues and I changed the UIDs from symbiansigned.com. Here is my mmp and pkg files.

    PKG File:

    ------------------------------------------------------------------

    &EN

    ; standard SIS file header
    #{"OIN_Player"},(0xA00030E4),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"CTools"

    ;Supports Series 60 v 3.0
    [0x200005FC], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)\Epoc32\release\$(PLATFORM)\$(TARGET)\VRex.exe" -"!:\sys\bin\VRex.exe"
    "$(EPOCROOT)\Epoc32\data\z\resource\apps\VRex.rsc" -"!:\resource\apps\VRex.rsc"
    "$(EPOCROOT)\Epoc32\data\z\private\A00030E7\apps\VRex_reg.rsc" -"!:\private\A00030E7\import\apps\VRex_reg.rsc"
    ;"$(EPOCROOT)Epoc32\data\z\resource\apps\OIN_Player_0xEE3BAC81.mif" -"!:\resource\apps\OIN_Player_0xEE3BAC81.mif"
    ;"$(EPOCROOT)\Epoc32\release\winscw\udeb\VRex.aif" -"!:\system\apps\VRex\VRex.aif"
    ;"..\help\OIN_Player_0xEE3BAC81.hlp" -"!:\resource\help\OIN_Player_0xEE3BAC81.hlp"

    ; Add any installation notes if applicable
    ;"OIN_Player.txt" -"!:\private\EE3BAC81\OIN_Player.txt"

    ;required for application to be covered by backup/restore facility
    "..\sis\backup_registration.xml" -"!:\private\EEF9CA31\backup_registration.xml"

    ----------------------------------------------------------------------

    MMP File:

    ----------------------------------------------------------------------

    TARGET VRex.exe
    TARGETTYPE EXE
    UID 0xA00030E5 0xE3D87210
    CAPABILITY LocalServices NetworkServices ReadUserData UserEnvironment WriteUserData
    LANG SC

    VENDORID 0
    SECUREID 0xA00030E7
    EPOCSTACKSIZE 0x5000

    SOURCEPATH ..\src
    SOURCE VRexApp.cpp
    SOURCE VRexAppUi.cpp
    SOURCE VRexDocument.cpp
    SOURCE VRexListView.cpp
    SOURCE VRexListContainer.cpp
    SOURCE VRexVideoView.cpp
    SOURCE VRexVideoContainer.cpp
    SOURCE VRexEngine.cpp
    SOURCE VRexRecorderAdapter.cpp
    SOURCE VRexPlayerAdapter.cpp
    SOURCE VRexViewFinder.cpp
    SOURCE VRexFileDetails.cpp
    SOURCE VRexFileDetailsDialog.cpp
    SOURCE VRexNaviDecoratorTime.cpp

    #ifdef _CARBIDE_CPP_
    SOURCEPATH ..\sis
    SOURCE OIN_Player_S60_3_X_v_1_0_0.pkg

    SOURCEPATH ..\gfx
    SOURCE VRex.mifdef
    SOURCE qgn_menu_VRex.svg
    #endif


    SOURCEPATH ..\data
    START RESOURCE VRex.rss
    HEADER
    TARGETPATH \resource\apps
    END

    START RESOURCE VRex_reg.rss
    TARGETPATH \private\A00030E7\apps
    END

    USERINCLUDE ..\inc
    SYSTEMINCLUDE \epoc32\include
    SYSTEMINCLUDE \epoc32\include\mmf\plugin
    SYSTEMINCLUDE \epoc32\include\mmf\common +\include\libc

    LIBRARY MMFControllerFramework.lib
    LIBRARY MediaClientVideo.lib // CVideoRecorderUtility
    LIBRARY ecam.lib // CCamera, MCameraObserver (in Onboard Camera)
    LIBRARY fbscli.lib
    LIBRARY gdi.lib
    LIBRARY euser.lib
    LIBRARY apparc.lib
    LIBRARY cone.lib
    LIBRARY eikcore.lib
    LIBRARY eikcoctl.lib
    LIBRARY avkon.lib
    LIBRARY commonui.lib
    LIBRARY apmime.lib
    LIBRARY aknskins.lib
    LIBRARY efsrv.lib
    LIBRARY commonengine.lib
    LIBRARY charconv.lib
    LIBRARY bafl.lib
    LIBRARY PlatformEnv.lib
    LIBRARY FeatDiscovery.lib //CFeatureDiscovery
    LIBRARY eikcdlg.lib eikctl.lib commdb.lib connmon.lib //CAknInformationnote
    --------------------------------------------------------------------

    I checked with the paths and they seem to be correct (Carbide use these paths by default). Have I made a mistake with my UIDs maybe?

    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Application does not appear after installation

    There can be many problems really, one thing I would check and ree-check that all information si absolutely correct in your reg.Rss file, it would be the first suspect.

    And then check the mmp file. This heppened to me last night infact also, I was copying old project to form a new one, and forgot the old secureID into the mmp file. All worked well in emulator, but only problem weat that the application didn't get registered, no error messages basically shown, the installer simply decided to install the app without problem, but didn't add the application into the list.

    yucca

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    17

    Re: Application does not appear after installation

    Thak you very much. This helped a lot. I managed to install it and find the icon but then I couldnt run it. Now I uninstalled it and tried to install it again and it says that the "component is built in"? How can i format and erase everything?

    Thanks
    Last edited by thefrozenrose; 2007-05-23 at 13:26.

  4. #4
    Regular Contributor
    Join Date
    Mar 2004
    Location
    Mobile Village - IN
    Posts
    78

    Re: Application does not appear after installation

    Full format - You can initate a full format from the HDD utilities and it is always recommended to use a charger. The full format process takes time and at the beginning the progress bar may appear to stopped but it is not. If you interrupt the full format by power cycling, battery going low then please ensure that you initiate a full format (not a quick format) and let it complete. Using quick format immediately after an aborted full format may cause unpredictable behaviour.

  5. #5
    Registered User
    Join Date
    Oct 2006
    Posts
    17

    Re: Application does not appear after installation

    Thank you very much for that. I now have another problem. I installed the application and found the icon. But when i open it, it doesnt do anything. No response not even an error.
    Does anyone know what this is?


    Thanks

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Application does not appear after installation

    That usually happens when your application leaves during the construction, i.e. the Appui's Construct is either never called, it it has a bug that causes it to leave.

    Possible causes that Appui's Construct is never called could be for example:
    1. Wrong UID returned by application
    2. Additional libraries defined in mmp that are not present in the system

    Basically, check the UID, see a bit of the libraries you have included, and then add logging code (write to RFile for example) in your Appui's ConstructL function to see which lines are getting ewxecuted.

    yucca

Similar Threads

  1. 3250 :: Cerificate Management :: No Application Installation Setting
    By lionel_lhf in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2006-06-14, 19:38
  2. After installation, I can't find the application in my Nokia 3650
    By winghui430 in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-03-22, 18:05
  3. Replies: 0
    Last Post: 2004-12-13, 11:05
  4. Application Doesnt Starts after Installation
    By amitaggarwal in forum Symbian
    Replies: 1
    Last Post: 2004-12-11, 06:39
  5. Installation problem, I can't create a new application with Sun Studio
    By minschk in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •