Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jul 2005

    Documentation doesn't work in Carbide 1.2 Express: "The webpage cannot be found"


    I've installed Carbide C++ 1.2 Express on my Win XP SP2 machine but can't get the built-in help to work. Whenever I open Help (for example by clicking Help menu -> Help Contents in Carbide), I get a new window displaying a "The webpage cannot be found - HTTP 404" error.

    I've also downloaded the S60_3rd_Ed_API_Reference_Update_1.0.1 standalone documentation and whenever I launch the eclipse.exe program contained in the uncompressed folder, all I get is a DocBrowser window displaying the same "The webpage cannot be found" error.

    Strangely enough, I haven't been able to find anybody else having the same problem on the Web.

    Has anybody an idea of what could be wrong on my setup?


  2. #2
    Registered User
    Join Date
    Jul 2005

    Re: Documentation doesn't work in Carbide 1.2 Express: "The webpage cannot be found"


    Gosh... took me a good 4 hours to get this one. I was on the verge of going mad. What a waste of time...

    The solution to this problem must be one of the weirdest thing i've seen in ages. If anybody else is having this problem, here is how I proceded:

    - Carbide is based on eclipse and therefore uses the eclipse engine for its help system. Nokia also distributes standalone documentation packages via forum Nokia which are also using the eclipse engine to display their content. So I downloaded the latest standalone doc (Cpp_Developers_Library_v1_0_standalone) to see if it worked and it also failed to work on my system. All I got when I launched the eclipse.exe program contained in the zip file as per the instruction was a "webpage cannot be found" error. So instead of trying to get the Carbide help to work, I decided to try to get the standalone documentation to work. The standalone doc is a lot simpler than the beast that Carbide is so troubleshooting the problem should be easier.

    - Looking for people having problems with the help on Carbide didn't bring up anything on Google. So I looked for reports of problems with the help in Eclipse and found a few discussions where people suggested to have a look at the log files to see if any errors are being reported. Actually, eclipse uses the tomcat server to serve its help file so for the standalone doc, the log file is located in Cpp_Developers_Library_v1_0_standalone\eclipse\workspace\.metadata\.plugins\org.eclipse.tomcat

    Looking in the log file, I saw that tomcat encountered an error when processing a jar file:
    Exception processing JAR at resource path /WEB-INF/lib/jsp.jar
    java.util.zip.ZipException: Access is denied

    Thing is, I had full access to all the files contained in the documentation folder so that error didn't make any sense.

    So back to Google. I ended up finding this discussion thread about Access denied exceptions with tomcat:

    I've got MacAfee VirusScan Enterprise 8 installed on my machine. But I'm actually running Windows on my Mac via Parallels Desktop which means that I've got very little chance of getting any viruses since I'm doing all the web browsing, emailing and downloading business on the Mac side. So in order to avoid MacAfee eating up all my resources for nothing, I've disabled all its features and I'm just keeping it in case I need to run a scan.

    And that's where the problem comes from. VirusScan has a feature called "On-Access scan" which automatically scans for viruses every file that's being accessed by any application on your system. Needless to say that this "feature" is a performance killer, really nasty stuff. So I obvioulsy had it disabled. Problem is that when On-Access scan was OFF, tomcat wouldn't work. Switching VirusScan On-Access scan ON solved the problem. Now tomcat works great which means that Nokia's standalone documentation and Carbide doc work just fine.

    Note that if you run into the same problem, you'll need to go to the Windows task manager and kill every javaw.exe process you see there after having re-enabled On-Access scan for tomcat to work.

    So as weird as it seems, the problem was caused by the fact that my anti-virus was switched OFF. Switching it back on was the solution. I guess that I'll simply uninstall MacAfee now, it wasted 4 hours of my time and there's little point keeping it given that I use Windows only to use development IDEs and that any "dangerous" things I do such as web browsing are done on the Mac side.

Similar Threads

  1. Error 1 file I/O fault when i upgraded to carbide express 1.1
    By seamus_rooney in forum Symbian Tools & SDKs
    Replies: 8
    Last Post: 2008-07-01, 22:16
  2. Carbide C++ 1.2 License Problem
    By meihao in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2008-02-28, 21:20
  3. Debugging Symbian S60 with Carbide C++ Express and NCF 1.2 Bluetooth
    By jimgilmour1 in forum Bluetooth Technology
    Replies: 4
    Last Post: 2006-09-05, 19:30
  4. Carbide express N-gage support
    By carnivash in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 7
    Last Post: 2006-04-08, 02:56
  5. Nokia SMIL Documentation does not work
    By Flitschbirne in forum General Messaging
    Replies: 2
    Last Post: 2005-08-03, 15:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts