×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2007
    Posts
    48

    The application does not display after installation

    Hi all,

    I've managed to install my application in a real device (Nokia 5500). However, after the installation, my application does not appear at all. What I have done are:

    1. Obtained a UID: 0x2000BAF8 from SymbianSigned.com
    2. Used the new UID in my code for: UID3 in MyProject_reg.rss, KUidMyProjectApp in MyProjectapplication.cpp, UID and SecureID in MyProject.mmp, UID in standard header file in MyProject.pkg
    3. Obtained a certificate from SymbianSigned.com
    4. Created and signed the sis file successfully

    My .pkg file is as follows:
    Code:
    ; MyProject.pkg
    ;
    ;Language - standard language definitions
    &EN
    
    ;Standard SIS file header
    #{"MyProject"},(0x2000BAEF),1,0,0
    
    ;Localised Vendor name
    %{"MyProject"}
    
    ;Unique Vendor name
    :"MyProject"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ;Files to install
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\release\gcce\urel\MyProject.exe"                 -"!:\sys\bin\MyProject.exe"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\Data\z\resource\apps\MyProject.rsc"               -"!:\resource\apps\MyProject.rsc"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\release\winscw\udeb\z\resource\apps\MyProject_reg.mif"               -"!:\resource\apps\MyProject_reg.mif"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\private\2000BAF8\apps\MyProject_reg.rsc"   -"!:\private\2000BAF8\import\apps\MyProject_reg.rsc"
    Please note that I had changed my target path in .mmp as follows:
    Code:
    START RESOURCE MDANTE_reg.rss 
      TARGETPATH                              \private\2000BAF8\apps 
    END
    If I don't use the new UID (i.e. 2000BAF8) but use the default UID (i.e. 0xe8d02aae), the application gets installed and displayed fine in the device. But in this case, the application cannot be signed by the certificate from SymbianSigned.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: The application does not display after installation

    the reg file should go under the import apps, in 10003a3f private folder, not your own.

    yucca

  3. #3
    Registered User
    Join Date
    May 2007
    Posts
    48

    Re: The application does not display after installation

    Quote Originally Posted by symbianyucca
    the reg file should go under the import apps, in 10003a3f private folder, not your own.

    yucca
    Thanks a lot. This helps.

Similar Threads

  1. Autorun the application after it's installation
    By alonish in forum Mobile Java General
    Replies: 4
    Last Post: 2005-11-21, 11:57
  2. Replies: 0
    Last Post: 2005-03-14, 04:07
  3. DB2E Application Installation Fail in Symbian 7 Emulator
    By darontan in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2005-03-03, 01:51
  4. Replies: 0
    Last Post: 2003-06-09, 04:46
  5. change application display title and icon
    By smallfish_ntu in forum Symbian
    Replies: 1
    Last Post: 2003-05-22, 03:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×