×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2007
    Location
    jakarta, indonesia
    Posts
    14

    problem capturing video, help!

    dear all,
    i have prob recording video using N70. my code is as described below part of it)
    public RecordMovie(Main parent) {
    //System.gc();
    this.setFullScreenMode(true);
    this.parent = parent;
    this.state = 0;
    this.errcode = 0;
    try {
    player = Manager.createPlayer("capture://audio_video");
    player.realize();
    recordControl = (RecordControl)player.getControl("RecordControl");
    String outputFile = System.getProperty("fileconn.dir.videos") + "MoRe.3gp";
    this.fileRecorded = outputFile;
    this.errcode = 200;
    FileConnection fc = (FileConnection)Connector.open(outputFile);
    this.errcode = 0;
    try {
    fc.delete();
    }
    catch (IOException ex) {
    }
    fc.create();
    fc.close();
    recordControl.setRecordLocation(outputFile);
    videoControl = (VideoControl)(player.getControl("VideoControl"));
    videoControl.initDisplayMode(VideoControl.USE_DIRECT_VIDEO, this);
    videoControl.setDisplayFullScreen(true);
    videoControl.setVisible(true);
    player.start();
    } catch (IOException ex){
    if(this.errcode == 0)
    this.errcode = 200;
    ex.printStackTrace();
    } catch (MediaException ex) {
    if(this.errcode == 0)
    this.errcode = 200;
    ex.printStackTrace();
    }
    //this.captureVideo();
    }//constructor

    the start record and stop record i put them in the keypressed function..
    the prob is that when i want to record, it only apperead white screen. not the recording screen.
    what should i do ?

    thanks for the help!

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: problem capturing video, help!

    My guess is that you should use the capture locator "capture://video" instead of capture://audio_video"
    I did not check the whole code completely, so something else could be wrong too, but start with making this change.

    Hartti

  3. #3
    Registered User
    Join Date
    May 2007
    Location
    jakarta, indonesia
    Posts
    14

    Re: problem capturing video, help!

    still not working
    i've tried to use capture:video, but this time although it's not white screen, it appeared that it's not able to get the access to the camera control...

    btw, isnt the capture:audio_video used for capturing sound also(in addition to video) ? i think u cannot get the sound recorded if u dont use audio_video..

    thanks.

Similar Threads

  1. Problem with video streaming using CVideoPlayerUtility
    By sajidul in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2007-07-18, 12:28
  2. 6600 video problem
    By jihane75 in forum Mobile Java General
    Replies: 4
    Last Post: 2007-03-09, 06:49
  3. Replies: 1
    Last Post: 2007-01-26, 12:18
  4. N90 Video editing - problem add Text to video
    By thongtom in forum General Development Questions
    Replies: 0
    Last Post: 2005-10-27, 09:47
  5. Video record problem in 7650?
    By ctchu1128 in forum Symbian
    Replies: 6
    Last Post: 2003-04-28, 17:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×