×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Registered User
    Join Date
    Jun 2007
    Posts
    4

    Issue with auto start app at device boot up for Symbian 9.1 OS

    Hello,

    Do you have any information regarding how to start application automatically at device boot up?

    I am following the below procedure for same.

    1) Create .rss file with the UID (2000B6B9) same as application UID.
    2) do the following entry in .rss file
    //////////////////////////////////////////////////////////////////////////////////////
    #include <startupitem.rh>
    RESOURCE STARTUP_ITEM_INFO DisconnectTone
    {
    executable_name = "!:\\sys\\bin\\DisconnectTone.exe";
    recovery = EStartupItemExPolicyNone;
    }
    /////////////////////////////////////////////////////////////////////////////////////

    3) copy .rss file into application's group folder
    4) Do the following entry in .mmp file for .rss file
    //////////////////////////////////////////////////////////////////////////////////////
    SOURCEPATH ..\group
    START RESOURCE 2000B6B9.rss
    TARGETPATH \private\101f875a\import
    HEADER
    END
    //////////////////////////////////////////////////////////////////////////////////////
    5) Build the project
    6) Do the following entry in .pkg file

    //////////////////////////////////////////////////////////////////////////////////////
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\private\101f875a\import\2000B6B9.rSC"-"c:\private\101f875a\import\[2000B6B9].rSC"
    ///////////////////////////////////////////////////////////////////////////////////////

    7) Create signed SIS by using "signsis tool "and install it on device.
    8) Reboot the device.

    Output: Application is not stared automatically

    Other Details :
    -Using device N73 (Symbian OS 9.1)
    -Developer signed SIS .
    -SDK S60-SDK-0548-3[1].0-f.3.215f
    -Application is GUI based .
    -Application has UID of protected range in my case it is 2000B6B9.
    -ReadUserData ,NetworkServices and SwEvent capabilities used by application.

    Query :Is it required to use S60-SDK-0616-3[1].0-mr.3.749 SDK rather then S60-SDK-0548-3[1].0-f.3.215f for auto start app .

    Please tell me the solution I am stucking with this issue from last week

    Thanx
    Shweta

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Quote Originally Posted by Shweta Jain
    Hello,

    Do you have any information regarding how to start application automatically at device boot up?

    I am following the below procedure for same.

    1) Create .rss file with the UID (2000B6B9) same as application UID.
    2) do the following entry in .rss file
    //////////////////////////////////////////////////////////////////////////////////////
    #include <startupitem.rh>
    RESOURCE STARTUP_ITEM_INFO DisconnectTone
    {
    executable_name = "c:\\sys\\bin\\DisconnectTone.exe";
    recovery = EStartupItemExPolicyNone;
    }
    /////////////////////////////////////////////////////////////////////////////////////

    3) copy .rss file into application's group folder
    4) Do the following entry in .mmp file for .rss file
    //////////////////////////////////////////////////////////////////////////////////////
    SOURCEPATH ..\group
    START RESOURCE 2000B6B9.rss
    TARGETPATH \private\101f875a\import
    HEADER
    END
    //////////////////////////////////////////////////////////////////////////////////////
    5) Build the project
    6) Do the following entry in .pkg file

    //////////////////////////////////////////////////////////////////////////////////////
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\private\101f875a\import\2000B6B9.rSC"-"c:\private\101f875a\import\[2000B6B9].rSC"
    ///////////////////////////////////////////////////////////////////////////////////////

    7) Create signed SIS by using "signsis tool "and install it on device.
    8) Reboot the device.

    Output: Application is not stared automatically

    Other Details :
    -Using device N73 (Symbian OS 9.1)
    -Developer signed SIS .
    -SDK S60-SDK-0548-3[1].0-f.3.215f
    -Application is GUI based .
    -Application has UID of protected range in my case it is 2000B6B9.
    -ReadUserData ,NetworkServices and SwEvent capabilities used by application.

    Query :Is it required to use S60-SDK-0616-3[1].0-mr.3.749 SDK rather then S60-SDK-0548-3[1].0-f.3.215f for auto start app .

    Please tell me the solution I am stucking with this issue from last week

    Thanx
    Shweta
    Hi shweta,

    ok try this code hope it'll help you.

    /////////////mmp file /////////////////////
    TARGET DisconnectTone.exe
    TARGETTYPE exe

    UID 0x0 0x2000B6B9
    SECUREID 0x2000B6B9

    LANG SC

    EPOCSTACKSIZE 0x5000

    SOURCEPATH ..\src
    SOURCE DisconnectTone.cpp

    START RESOURCE 2000B6B9.rss
    TARGETPATH \private\101f875a\import

    END

    SYSTEMINCLUDE . \epoc32\include

    LIBRARY euser.lib

    //////////////////////////2000B6B9.rss
    #include <startupitem.rh>
    RESOURCE STARTUP_ITEM_INFO DisconnectTone
    {
    executable_name = "!:\\sys\\bin\\DisconnectTone.exe";
    recovery = EStartupItemExPolicyNone;
    }

    ////////////////////////DisconnectTone.cpp/////////////////
    //system include
    #include <e32base.h>
    #include <e32cons.h>

    LOCAL_C void ExeMainL()
    {
    User::After(12000000)
    //To give few time for proper starting ...
    ///To do here code ...............

    }

    GLDEF_C TInt E32Main()
    {
    __UHEAP_MARK;
    CTrapCleanup* cleanup = CTrapCleanup::New();

    TRAPD(error, ExeMainL());
    __ASSERT_ALWAYS(!error, User::Panic(_L("DIsconnectTone"), error));

    delete cleanup;
    __UHEAP_MARKEND;

    return 0;
    }

    ///////////////////////////////////

    I m sure, It'll work for you...

    Keep going..!

  3. #3
    Registered User
    Join Date
    Jun 2007
    Posts
    4

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    hi ,

    I have tried with the details provided by you but it's not working .Please clarify me that I have to use the MR release version of 9.1 for auto stat app at boot up .

    I am using developer signed SIS not the Symbina Signed with the procted range ID

    Thanx
    Shweta

  4. #4
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Post your entire pkg file

    I am also assuming you can actually start and run the application from the main menu?
    Last edited by Paul.Todd; 2007-06-05 at 13:46.

  5. #5
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Smile Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Hi,

    Also check out the following link from wiki: How to autostart an application on boot up in 3rd- Startup List Management API

    Kiran.

  6. #6
    Registered User
    Join Date
    Jun 2007
    Posts
    4

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Hi,

    Below is the code of pkg file :

    //////////////////////////////////////////////////////////////////////////////////////
    ; DisconnectTone.pkg

    ; Languages
    &EN

    ; Header
    #{"DisconnectTone"},(0x2000B6B9), 1, 01, 1, TYPE=SISAPP

    ; Platform compatibility
    [0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"Vendor Name"}
    :"Vendor Name"


    ; Target
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\DisconnectTone.rSC"-"!:\resource\apps\DisconnectTone.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\EndTImages.mbm"-"!:\resource\apps\EndTImages.mbm"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\DisconnectTone.mbm"-"!:\resource\apps\DisconnectTone.mbm"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\DisconnectTone_reg.mif"-"!:\resource\apps\DisconnectTone_reg.mif"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\private\10003a3f\apps\DisconnectTone_reg.rSC"-"!:\private\10003a3f\import\apps\DisconnectTone_reg.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\gcce\UREL\DisconnectTone.exe"-"!:\sys\bin\DisconnectTone.exe", FR,RI
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\private\101f875a\import\2000B6B9.rSC"-"c:\private\101f875a\import\[2000B6B9].rSC"
    "C:\[2000B6B9].RSC"-"C:\[2000B6B9].RSC"
    "C:\tones\A Perfect Day.wav"-"!:\tones\A Perfect Day.wav"
    "C:\announcer.mid"-"!:\ETSupport\announcer.mid"
    "C:\vibrate.mid"-"!:\ETSupport\vibrate.mid"
    ""-"C:\tones\*.*", FN
    ""-"C:\ETSupport\*.*", FN
    //////////////////////////////////////////////////////////////////////////////////////

    I am pressing the menu key of device to check, Is application launches in background on device booth up or not .

  7. #7
    Nokia Developer Expert
    Join Date
    Feb 2005
    Location
    India
    Posts
    209

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Hi all,
    Is it possible to load an exe other than the application exe. ie; am installing another exe along with the application installation files. During device reboot i need to run this new exe.

    Thanks,
    Anoop
    Anoop..

  8. #8
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Hi,

    i think you can install other exe also with your own application sis file.
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  9. #9
    Nokia Developer Expert
    Join Date
    Feb 2005
    Location
    India
    Posts
    209

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    hi KKrish,
    i tried that but the exe was not working. Like i was able to reboot the application exe , but when tried with another exe nothing happend.
    Anoop..

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    How does "other exe" appear in your .pkg and [xxx].rss file?

  11. #11
    Nokia Developer Expert
    Join Date
    Feb 2005
    Location
    India
    Posts
    209

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    hi..
    Please go through the following details

    ; Recorder.pkg

    ; Languages
    &EN

    ; Header
    #{"MobileRecorder"},(0xe53e8019), 0, 1, 1

    ; Platform compatibility
    [0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"Vendor Name"}
    :"Vendor Name"

    ; Target
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\gcce\UREL\MobileRecorder.exe"-"!:\sys\bin\MobileRecorder.exe"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\MobileRecorder.rSC"-"!:\resource\apps\MobileRecorder.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\MobileRecorder_reg.mif"-"!:\resource\apps\MobileRecorder_reg.mif"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\private\10003a3f\apps\MobileRecorder_reg.rSC"-"!:\private\10003a3f\import\apps\MobileRecorder_reg.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\recomate1.exe"-"!:\sys\bin\recomate1.exe"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Start.amr"-"!:\System\Apps\MobileRecorder\start.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Stop.amr"-"!:\System\Apps\MobileRecorder\Stop.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Play.amr"-"!:\System\Apps\MobileRecorder\play.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\test.txt"-"!:\System\Apps\MobileRecorder\test.txt"


    Here the exe path is as follows

    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\recomate1.exe"-"!:\sys\bin\recomate1.exe"

    In [e53e8019].rss file

    #include <startupitem.rh>

    RESOURCE STARTUP_ITEM_INFO startexe
    {
    executable_name = "!:\\sys\\bin\\recomate1.exe";
    recovery = EStartupItemExPolicyNone;
    }
    Anoop..

  12. #12
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Quote Originally Posted by anoopd
    hi..
    Please go through the following details

    ; Recorder.pkg

    ; Languages
    &EN

    ; Header
    #{"MobileRecorder"},(0xe53e8019), 0, 1, 1

    ; Platform compatibility
    [0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"Vendor Name"}
    :"Vendor Name"

    ; Target
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\gcce\UREL\MobileRecorder.exe"-"!:\sys\bin\MobileRecorder.exe"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\MobileRecorder.rSC"-"!:\resource\apps\MobileRecorder.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\resource\apps\MobileRecorder_reg.mif"-"!:\resource\apps\MobileRecorder_reg.mif"
    "C:\Symbian\9.1\S60_3rd\Epoc32\data\z\private\10003a3f\apps\MobileRecorder_reg.rSC"-"!:\private\10003a3f\import\apps\MobileRecorder_reg.rSC"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\recomate1.exe"-"!:\sys\bin\recomate1.exe"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Start.amr"-"!:\System\Apps\MobileRecorder\start.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Stop.amr"-"!:\System\Apps\MobileRecorder\Stop.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\Play.amr"-"!:\System\Apps\MobileRecorder\play.amr"
    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\test.txt"-"!:\System\Apps\MobileRecorder\test.txt"


    Here the exe path is as follows

    "C:\Symbian\9.1\S60_3rd\Epoc32\release\GCCE\UREL\recomate1.exe"-"!:\sys\bin\recomate1.exe"

    In [e53e8019].rss file

    #include <startupitem.rh>

    RESOURCE STARTUP_ITEM_INFO startexe
    {
    executable_name = "!:\\sys\\bin\\recomate1.exe";
    recovery = EStartupItemExPolicyNone;
    }

    you can launch the exe from StartExe using RProcess. launch the other process from the urrent running may be that is i think start exe that you have
    executable_name name must be same as startexe.
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  13. #13
    Nokia Developer Expert
    Join Date
    Feb 2005
    Location
    India
    Posts
    209

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    hi KKrish,
    I tried as you suggested by changing the name of the exe ie; recomate1 to startexe.exe. Then also the exe failed to run on reboot. Check whether the exe is got any issue by triggering the exe from the application. The exe works fine. What could be wrong for this behaviour.


    Please give suggestions..
    Anoop..

  14. #14
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Actually I cannot see where you install [e53e8019].rsc.

  15. #15
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: Issue with auto start app at device boot up for Symbian 9.1 OS

    Hello Anoop,

    Have you really gone through:
    http://wiki.forum.nokia.com/index.ph...Management_API

    As wizard_hu_ suspects, where is the line [e53e8019].rsc?

    Kiran.

Similar Threads

  1. Replies: 1
    Last Post: 2012-04-04, 09:56
  2. Replies: 0
    Last Post: 2005-07-27, 12:03
  3. Replies: 2
    Last Post: 2005-06-25, 06:03
  4. Stability issue with own RFCOMM app on 6230
    By kawk in forum Bluetooth Technology
    Replies: 0
    Last Post: 2004-10-02, 09:41
  5. Replies: 1
    Last Post: 2002-12-09, 11:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×