×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Apr 2007
    Location
    Bangalore, India
    Posts
    81

    Connection problem with S80 Emulator

    hi,

    i am developing a small thin Email client which will use HTTP conenction to connect to server.

    but when i have tested my app on S80 emulator its not connecting to server at all. we have to do any setting for network connection?

    plz help me on this.

    thanks in advance.

  2. #2
    Registered User
    Join Date
    Oct 2006
    Posts
    30

    Re: Connection problem with S80 Emulator

    1) Make sure you have the right GPRS profiles selected...

    2) Please elaborate your problem and post the code
    Sreekanth Bellur,
    Symbian C++ Developer,
    Ravensoft Ltd.,
    Manchester,
    United Kingdom

  3. #3
    Regular Contributor
    Join Date
    Apr 2007
    Location
    Bangalore, India
    Posts
    81

    Re: Connection problem with S80 Emulator

    Thanks sreekanth.

    when my emulator tries to connect to server its displaying 2 option for me to select for. 1) GSM Data 2) Using WLAN. i am trying to connect using WLAN.

    the code what i am using is as below.

    private HttpConnection connection;
    private DataOutputStream output;

    try {
    connection = (HttpConnection) Connector.open(URL,
    Connector.READ_WRITE, true);
    output = connection.openDataOutputStream();
    output.write(data);
    }
    catch(ConnectionNotFoundException cnfe){
    }
    finally {
    output.flush();
    if (output != null) {
    output.close();
    output = null;
    }

    if (connection != null) {
    connection.close();
    connection = null;
    }
    System.gc();
    }

    I am using S80 DP2 SDK emulator for testing.

    the code is working fine on other S40 and S60 devices and emulators.

    let me know if i am doing any thing wrong or is i have to do any setting on emulator for connection?

  4. #4
    Registered User
    Join Date
    Oct 2006
    Posts
    30

    Re: Connection problem with S80 Emulator

    does it work when you select the GSM option on the emulator network settings ? have you tested it on a real S80 device such as 9500 and if yes, does it work on the device ?
    Sreekanth Bellur,
    Symbian C++ Developer,
    Ravensoft Ltd.,
    Manchester,
    United Kingdom

  5. #5
    Regular Contributor
    Join Date
    Apr 2007
    Location
    Bangalore, India
    Posts
    81

    Re: Connection problem with S80 Emulator

    HI,

    i have tried with selecting GSM data also but no luck.

    i dont have any S80 device with me. so i am trying to test on emulator only.

    is it any thing else that i am missing?

  6. #6
    Regular Contributor
    Join Date
    Apr 2007
    Location
    Bangalore, India
    Posts
    81

    Re: Connection problem with S80 Emulator

    hi,

    my S80 emulator is not at all connecting to server. when i am connecting server the emulator only is crashing.

    any nokia expert can put some focus on this?

    plz plz its badlly needed.

  7. #7
    Regular Contributor
    Join Date
    Apr 2007
    Location
    Bangalore, India
    Posts
    81

    Re: Connection problem with S80 Emulator

    hi,

    now i have changed my code a bit. instead of dataOutPutStream i have used only outputStream. so now the request is going to server and server is sending the response also. but i never got the response back to client.

    sometimes emulator only is crashing.

    plz plz help me on this.

Similar Threads

  1. Connecting to Sync4j server from Nokia S80 emulator
    By karhudev in forum OMA DM/DS/CP
    Replies: 0
    Last Post: 2005-09-10, 14:44
  2. GPS - Bluetooth connection problem
    By can_bal99 in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2005-08-22, 13:11
  3. Problem: RGenericAgent::Progress does not detect open connection
    By bjorn.rudolfsson in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2004-02-18, 08:59
  4. socket connection problem
    By bhatti81 in forum Mobile Java General
    Replies: 2
    Last Post: 2003-10-08, 14:43
  5. 7650/3650 Emulator and GPRS Connection problem
    By joller in forum Mobile Java General
    Replies: 1
    Last Post: 2003-04-11, 00:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •