I have installed 'Sun[tm] ONE Studio 4 update 1 (Mobile Edition)' with 'Java2 SDK 1.4.1' from SUN and as far as i know it is enough to develop complete Midlets for my 7210.

But what is the Nokia Developer's Suite 1.0 for J2ME? and Nokia 7210 MIDP SDK Beta 0.1 for??

They can work together with the SUN products? and if i use the Nokia SDK .. means my Midlets can only work on Nokia 7210??

Thanks