×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    May 2007
    Posts
    51

    Capabilities problem

    Hello,

    I created an application that needs access to Bluetooth and I included the LocalServices and NetworkServices in the CAPABILITY field of my .mmp file.
    I recompiled my project from Carbide c++ and tried to install it but it still only showed me the request for Read user data.
    Then I read in the documentation that Carbide doesn't process the info in the bld.inf and .mmp files.
    So I tried compiling and creating my .sis from the command line.
    Everything worked ok and I noticed that my executable was a lot bigger 96KB instead of just 19KB from within Carbide c++.
    So when I tried to install the newly created .sis (self-signed) to my phone it starts installing it but then gets stuck at about 75%.

    I hope someone can help me out.
    Here are my .mmp:
    Code:
    TARGET		PhoneMuse.exe
    TARGETTYPE  	exe
    SecureID			0xEF3ED4C5
    UID			0x0 0xEF3ED4C5 
    VENDORID		0x0
    CAPABILITY READUSERDATA LocalServices NetworkServices 
    
    EPOCSTACKSIZE	0x5000
    
    SOURCEPATH ..\src
    SOURCE  PhoneMuse.cpp 
    SOURCE  PhoneMuseApplication.cpp 
    SOURCE  PhoneMuseAppui.cpp
    SOURCE  PhoneMuseAppView.cpp
    SOURCE  PhoneMuseDocument.cpp
    SOURCE  BT.cpp
    SOURCE  BTServiceAdvertiser.cpp
    
    SOURCEPATH ..\data
    
    START RESOURCE PhoneMuse.rss
    HEADER
    TARGETPATH resource\apps
    END
    
    START RESOURCE PhoneMuse_reg.rss
    #ifdef WINSCW
    TARGETPATH 	  \private\EF3ED4C5\apps
    #else
    TARGETPATH 	  \private\EF3ED4C5\import\apps
    #endif
    END
    
    USERINCLUDE . 
    USERINCLUDE ..\inc
    
    SYSTEMINCLUDE  . \epoc32\include
    SYSTEMINCLUDE  \epoc32\include\libc
    
    LIBRARY euser.lib
    LIBRARY apparc.lib
    LIBRARY cone.lib 
    LIBRARY eikcore.lib  hb
    LIBRARY avkon.lib  
    LIBRARY bafl.lib
    LIBRARY bluetooth.lib 
    LIBRARY btextnotifiers.lib
    LIBRARY sdpagent.lib
    LIBRARY sdpdatabase.lib
    LIBRARY commonengine.lib
    LIBRARY insock.lib
    LIBRARY esock.lib
    
    LANG SC
    and my .pkg
    Code:
    ; Installation file for PhoneMuse application
    ;Language - standard language definitions
    &EN
    
    ; standard SIS file header
    #{"PhoneMuse"},(0xEF3ED4C5),1,0,0
    
    ;Localised Vendor name
    %{"Vendor-EN"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\BUILD\Symbian\Carbide\workspace\PhoneMuse\group\PHONEMUSE\GCCE\urel\PhoneMuse.exe"        -"!:\sys\bin\PhoneMuse.exe"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\resource\apps\PhoneMuse.rsc"        -"!:\resource\apps\PhoneMuse.rsc"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\private\10003a3f\apps\PhoneMuse_reg.rsc"    -"!:\private\10003a3f\import\apps\PhoneMuse_reg.rsc"
    "C:\Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\resource\apps\PhoneMuse.mif" -"!:\resource\apps\PhoneMuse.mif"
    
    ; Add any installation notes if applicable
    ;"PhoneMuse.txt"        -"!:\private\EF3ED4C5\PhoneMuse.txt"
    
    ;required for application to be covered by backup/restore facility 
    "..\sis\backup_registration.xml"		-"!:\private\EF3ED4C5\backup_registration.xml"

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,750

    Re: Capabilities problem

    Carbide (at least 1.0 and 1.1) does not care about your .mmp file. Add capabilities in Project/Properties/C/C++ Build/on the right (default tab - Tool Settings/System Options).

  3. #3
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Capabilities problem

    Use Carbide 1.2 its much better at doing this kind of stuff

  4. #4
    Regular Contributor
    Join Date
    May 2007
    Posts
    51

    Re: Capabilities problem

    Yeah, I finally found the dialog to put in the capabilities...
    Things are just too complicated.

  5. #5
    Registered User
    Join Date
    May 2007
    Posts
    27

    Re: Capabilities problem

    Hi all,

    I'm working on a project which just uses an UDP socket, therefore I think I just need the 5 basic capabilities (UserEnvironment, LocalServices, NetworkServices, WriteUserData and ReadUserData).
    I added them using the MMP editor in Carbide.c++ Pro 1.2. I searched the project Properties in case I needed to set them there too, but I didn't find where, so I think that the MMP editor does it all, in the same way it adds the libraries automatically.

    The problem is, I still get the error code -46, "unable to execute file for security reasons", which I believe has to do with capabilities.

    I tried to solve that using Symbian Signed Open Signed online application, but the sis they sent keeps giving the same error.

    Where is the problem then? How can I fix it? Is it because of some Carbide option I'm missing?

    Please, I need some help because I'm stuck in such a basic step of my project.

    BR,

    Estrella

  6. #6
    Registered User
    Join Date
    May 2007
    Posts
    27

    Re: Capabilities problem

    Sorry, I was using WriteDeviceData and ReadDeviceData wrongly. I've removed them from my project and now it executes OK.

Similar Threads

  1. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  2. SIP capabilities problem
    By ademar123 in forum Symbian
    Replies: 0
    Last Post: 2005-05-11, 15:32
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×