×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Sep 2006
    Location
    Berlin
    Posts
    59

    SDK 3rd FP3: Emulator crashes at startup: KERN-EXEC 3

    Hello Carbide users,

    I just have installed Carbide.c++ 1.2 express, the S60 SDKs 2nd FP3, tested the Hello World Example from the SDK in Emulator and on an Nokia N90. It's OK.
    Then I have installed the SDK 3rd FP1 and have tried the example for a 3rd ed. GUI application (also a Hello world). I first build for the emulator. But when launching the emulator from Carbide first it took several minutes showing a blank screen then the S60 logo appeared with the pink, green and blue lines and almost the same moment:

    Application closed:
    Standby mode
    KERN-EXEC 3

    -> OK

    Application closed:
    Startup
    Startup 10002

    -> OK

    Phone start-up
    failed. Contact the
    retailer.

    It doesn't matter whether the emulator is launched by Carbide or started from the command line or via Windows Icon. There's always the same result.
    When launched by Carbide there is no problem in the debug window, just hundred times "Thread [Tread id: xxxxx](Running). New threads seem still to be started after the error occurs.

    It looks a little bit like the often reported error with the NCNlist. But in difference to that after the crash no further operation is possible. In other words: the normal screen where you start the application from does not appear at all! The emulator is worthless.

  2. #2
    Regular Contributor
    Join Date
    Sep 2006
    Location
    Berlin
    Posts
    59

    SDK 3rd FP3: New error: CbsServer -21

    I could fix the problem by deinstalling and again reinstalling the SDK. In difference to the first time I have launched the emulator immediately after installation but without any new programs build by Carbide.C++.

    Later when I was back in my normal working account on Windows XP (installation requires admin account) I again launched the emulator and got following error after startup:

    Application closed:
    CbsServer
    CbsServer -21

    After clicking OK the emulator runs normally.
    It seems there are dependencies upon the account and permissions. This is absolutely not acceptable, at least not for a normal working account. I cannot do daily work as administrator, at home for security reasons and in a company it may not be allowed.

    Regards, Karsten

Similar Threads

  1. Recording audio in AMR format, SDK 3rd
    By handle_cn in forum Symbian
    Replies: 12
    Last Post: 2007-11-03, 08:16
  2. MMF in the 3rd Edition SDK
    By sameet in forum Symbian Media (Closed)
    Replies: 7
    Last Post: 2006-08-14, 03:08
  3. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  4. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×