×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    May 2007
    Posts
    51

    Question Carbide v1.2 has trouble recognizing changes in code

    Hi,

    I don't know what I am doing wrong.
    But I commented out part of my program and built the project again.
    The console window in carbide showed that it compiled the code succesfull.
    After installing the sisx on my phone (Nokia5500) the program is still executing the removed part of the program.
    Apparently Carbide did not notice the changes in the code.
    So I tried using "Clean project" and then "Build project" but I got an error message from makesis.
    After restarting carbide I could build the project but the program is still executing different code.
    I used
    Code:
    text.Format(_LIT("%d %d %d %d %d"), aX, aY, aZ, 0, 0);
    iInfoLabel->SetTextL(text);
    iInfoLabel->SetExtent(TPoint(10, 10), iInfoLabel->MinimumSize());
    drawDereffered();
    where text is a TBuf<50> and aX, aY, aZ are TInt16.
    iInfoLabel is showing the correct values for aX, aY, aZ but after that I get some values that I used before.

    I don't know what's going on.
    Any help on resolving this issue is greatly appreciated.
    Thanks
    codepatch

  2. #2
    Regular Contributor
    Join Date
    May 2007
    Posts
    51

    Re: Carbide v1.2 has trouble recognizing changes in code

    I finally figured out what was wrong:
    When debugging the application the wrong sisx file got installed on the phone.
    Actually that sisx file was out-of-sync with the source code.
    Somehow the debugger should be able to find out about such a problem.

Similar Threads

  1. Problems with Carbide C++ v1.2
    By erst in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2007-06-21, 17:19
  2. Carbide not recognizing installed UIQ SDK
    By Teknomancer in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2007-05-23, 13:58
  3. Replies: 0
    Last Post: 2003-02-24, 04:00
  4. 6510 wallet code resets itself
    By o00ze in forum Mobile Commerce
    Replies: 1
    Last Post: 2003-02-05, 09:29
  5. problem with Nokia Toolkit 3.1 and binary code for MMS
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-08-09, 06:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×