×

Discussion Board

Results 1 to 10 of 10

Thread: SOS

  1. #1
    Registered User
    Join Date
    Jun 2007
    Posts
    7

    SOS

    Hi,

    I've just installed carbide 1.2 with the S60 3rd ed. SDK and would like to compile and run the simplest example ("hello world"). I succeeded in building it for the emulator, but building for the target (using GCCE) fails:

    make -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\UME\SVN\LiorG\Symbian\Workspace\Hello\group\GCCE.make" LIBRARY
    \Symbian\9.1\S60_3rd\EPOC32\BUILD\UME\SVN\LiorG\Symbian\Workspace\Hello\group\HELLO\GCCE\HELLO.GCCE:76: *** missing separator. Stop.
    make -C \UME\SVN\LiorG\Symbian\Workspace\Hello\HELP -f "BUILD_HELP.MK" TO_ROOT=..\..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\..\Symbian\9.1\S60_3rd\EPOC32\BUILD\UME\SVN\LiorG\Symbian\Workspace\Hello\group\BUILD_HELP\GCCE TO_BLDINF=..\..\..\..\..\..\..\UME\SVN\LiorG\Symbian\Workspace\Hello\group PLATFORM=GCCE LIB
    make: *** [LIBRARYHELLO] Error 2
    The file HELLO.GCCE around 76 reads:
    ifndef CC_INSTALL_PATH
    CC_INSTALL_PATH=libgcc.a
    \..
    STATIC_LIBS = $(STATIC_LIBS_PATH)"$(CC_INSTALL_PATH)\arm-none-symbianelf\lib" $(STATIC_LIBS_PATH)"$(CC_INSTALL_PATH)\lib\gcc\arm-none-symbianelf\3.4.3"
    I just can't work it out... Please help...

    Thanks!
    Last edited by mobilesolid; 2007-06-24 at 14:59.

  2. #2
    Registered User
    Join Date
    Jun 2007
    Posts
    10

    Re: SOS

    I need help with this too. I have exactly the same problem.

    Anyone figured it out yet?

    How do I fix the "missing separator" error? It has been rather annoying.

    The line of code in the GCCE file reported to be causing the error is in red below:
    Code:
    ifndef CC_INSTALL_PATH
    	CC_INSTALL_PATH=libgcc.a
    \..
    
    endif
    	GCC_LIB_PATH=libgcc.a

  3. #3
    Registered User
    Join Date
    Jun 2007
    Posts
    7

    Re: SOS

    Do you have any ideas how to overcome this problem?

  4. #4
    Registered User
    Join Date
    Jun 2007
    Posts
    10

    Re: SOS

    No idea at all. I am starting with a fresh installation of Perl, S60 SDK, and Carbide C++ and yet I cannot build the tutorial example with GCCE configuration successfully.

    And I have tried on two computers.

    Maybe try posting in a new thread. No offence but I guess the thread title "SOS" is not catching much attention and interest from experts.

  5. #5
    Registered User
    Join Date
    Jun 2007
    Posts
    7

    Re: SOS

    You're right about the title, but I've no idea how to make such a stupid problem interesting :).
    Anyway, I tried the installation on Windows XP (as opposed to Vista) and it compiled...
    I still need to figure out how to do it on Vista, though.

  6. #6
    Registered User
    Join Date
    Jun 2007
    Posts
    10

    Re: SOS

    Oh I'm running Vista too. But I thought it also didn't work on my XP PC.
    Got to try it again.

    If it is really a Vista problem, we would need an expert who can help us tweak the configuration so that it can build normally like in XP.

    Running Carbide in Vista's XP compatibility mode does not seem to work.

  7. #7
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: SOS

    Quote Originally Posted by stratosphere27
    Oh I'm running Vista too. But I thought it also didn't work on my XP PC.
    Got to try it again.

    If it is really a Vista problem, we would need an expert who can help us tweak the configuration so that it can build normally like in XP.

    Running Carbide in Vista's XP compatibility mode does not seem to work.
    Hi,

    Although I havent really tried, but there were some interesting suggestions (looks promising) by Jim in one discussion. You might find it useful.

    Hope it helps.

    Good luck and cheers
    Neil

  8. #8
    Registered User
    Join Date
    Jun 2007
    Posts
    10

    Re: SOS

    Hi Symbian Neil,

    Thank you! The guide by Jim works. I can now build on Vista.

    mobilesolid, follow the guide and remember to see the wiki for details to modify some files.

  9. #9
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: SOS

    Quote Originally Posted by stratosphere27
    Hi Symbian Neil,

    Thank you! The guide by Jim works. I can now build on Vista.

    mobilesolid, follow the guide and remember to see the wiki for details to modify some files.
    Glad that it helped you :)

    Cheers
    Neil

  10. #10
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: SOS (New Vista Wiki Page)

    Hello all,

    I have started a Wiki page "Moving to Vista (tm)" which I update when I have something new on a SDK running on Vista (tm)

    http://wiki.forum.nokia.com/index.ph...Vista_%28tm%29

    Jim

Similar Threads

  1. SOS!!! Cant replace icon for my app
    By chishti.hameed in forum Symbian User Interface
    Replies: 1
    Last Post: 2005-06-08, 09:02
  2. SOS!! how can a phone ID be retrieved from SMS
    By chishti.hameed in forum Symbian Networking & Messaging (Closed)
    Replies: 8
    Last Post: 2005-06-02, 05:10
  3. SOS S40Sound API resume()
    By pcmorning in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2005-05-26, 03:08
  4. SOS!! how can a phone ID be retrieved from SMS
    By chishti.hameed in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2005-05-02, 12:18
  5. SOS about show chinese!
    By dyhunter in forum Browsing and Mark-ups
    Replies: 8
    Last Post: 2005-02-25, 06:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×