×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    6

    Question N95 problem with local video file playback

    I have a mmapi application that plays back video files. I use locally stored 3gp/mp4 files. That application runs on this devices:
    - N92, N80, N76, N73
    - E60, E61
    My tries with a fresh updated N95 were not successfully. It seems to me as if just in the case I use Manager.createPlayer(java.lang.String locator) with a locator pointing a local file the resulting player does not play anything. There is no expeption, the J2ME application still works. But I see no video playing. In the case of a locator pointing to a http video stream the player works fine (tested with videoplayer demo from symbian.com).
    In case of using Manager.createPlayer(java.io.InputStream stream, java.lang.String type) I see after a long time the video playing, but the CPU gets under heavy load and the J2ME application gets unuseable.

    I used that code to create a player basing on a InputStream:
    FileConnection fcon =
    (FileConnection) Connector.open(clip.getClipFilePath(), Connector.READ);
    if (fcon != null && fcon.exists() && !fcon.isDirectory() && fcon.canRead()) {
    newPlayer = Manager.createPlayer(new fcon.openInputStream(),
    "video/3gp");

    I used that code to create a player basing local locater:
    newPlayer = Manager.createPlayer(clip.getClipFilePath());

    I can not understand why my application works on N76 (S60 3rdFP1), but not on N95 (also S60 3rdFP1).

    Does any one know what to do ?

  2. #2
    Registered User
    Join Date
    Jan 2006
    Posts
    6

    Red face Re: N95 problem with local video file playback

    I found the solution. N95, E90 and N93 do not like more than one VideoPlayer instance. To accelerate clip skipping I had always 3 VideoPlayers (prev, current, next) instances. With just one instance a time my VideoPlayer operates again like I expect it.

    On all other already tested devices had a problem with more than one VideoPlayer in prefetch-state. prev und next VideoPlayer had to be in realize-state.

    bye,
    der Micha

  3. #3
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: N95 problem with local video file playback

    Thanks for sharing the information Micha!

    Hartti

  4. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    1

    Re: N95 problem with local video file playback

    I Have a similar problem with sounds. I've tried some test apps but they did not work on my n95.

    I tried generating a sound using manager.playTone and playing a .wav file using manager.createPlayer but both didn't work.

    Has anybody an idea or the same problem?
    Can someone probably write a program that works on his n95 and send it to me?

    Thanks.

Similar Threads

  1. File Writing Problem in S60
    By Asif Nazir in forum Symbian User Interface
    Replies: 9
    Last Post: 2007-04-27, 07:15
  2. Problem playing .mpg video example with Nokia SDK 4.0
    By ninku6a in forum Mobile Java Media (Graphics & Sounds)
    Replies: 16
    Last Post: 2006-11-15, 07:30
  3. Show Video File in Profiles of the Device
    By yogesh14 in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2006-03-27, 08:30
  4. Problem in opening a video...
    By anoopd in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2005-02-21, 15:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •