×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2007
    Location
    India
    Posts
    25

    Exclamation Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    Hi All,

    Currently i am working on browser APIs of the S603rd FP1.
    I found some weird things happening when i execute the code...
    following is the sequence of actions i executed on FP1.

    I ported the browser (iBrCtlInterface object created in my own application) of S60 3rd ed to FP1. It compiled well, but when I executed it I found that LoadDataL() API which i use to load html data in the browser was not showing anything on the screen (whereas It properly shows on S60 3rd).

    While debugging, i came across an interesting thing, every call of LoadDataL ..it was calling ResolveLinkL (which must get call when i click on link....not when LoadDataL APi executed). So i removed the observer, and debug once more. I found LoadDataL working and showing data properly.

    I have to implement the LinkResolver too. But if i add it, LoadDataL stops working. I have to use LoadDataL only..no any other option.

    Please can anyone guide me in this weird problem??
    I just dont understand, whats wrong with it. Is there any major change in FP1browser API?? OR Is there any way to add observers after creating browser object??

    Please help me

    Thanks to all genius ppl in advance

    -Manasi

  2. #2
    Registered User
    Join Date
    Oct 2006
    Location
    Tampere Finland
    Posts
    76

    Re: Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    Could you please send me your code to display data itself. I am stuck with it.

    Thanks a lot in advance.

  3. #3
    Registered User
    Join Date
    Jan 2007
    Location
    India
    Posts
    25

    Re: Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    I have posted reply to ur query in ur earlier thread.
    While creating the browser control, just remove the LinkResolver observer and pass NULL instead.

  4. #4
    Registered User
    Join Date
    Oct 2006
    Location
    Tampere Finland
    Posts
    76

    Re: Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    I have done that but its still not working........

    Please help.

  5. #5
    Registered User
    Join Date
    Jan 2007
    Location
    India
    Posts
    25

    Re: Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    Did u even remove the capability TBrCtlDefs::ECapabilityClientNotifyURL ????

  6. #6
    Registered User
    Join Date
    Oct 2006
    Location
    Tampere Finland
    Posts
    76

    Re: Problems in the Browser( iBrCtlInterface) of S60 3rd Fp1

    I am using just one capability TBrCtlDefs::ECapabilityDisplayScrollBar now.

Similar Threads

  1. Replies: 2
    Last Post: 2007-06-12, 15:04
  2. S60 3rd Ed FP1 Emulator Error
    By napperley in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2007-04-03, 01:04
  3. Dropdownlist selection closes browser in s60 skd 3rd ed
    By sekou in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-09-29, 23:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •