×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Jun 2007
    Posts
    28

    J2ME application doesnt open

    Hi Everyone,

    I have a weird problem. I have a J2ME application that works on motorola iDen phones. I was trying to use the same application in Nokia 7610 phone and the application doesnt open. I tried to catch the exception but no exception is thrown. I tried all kinds of debugging the code and it doesnt work. Ohh by the way it opens the application in Nokia E62. I have no clue with this behavior. Can any please help me out. I having some tight deadlines.

    Also I forgot to mention. This application works perfectly on WTK2.2 simulator. No issues at all.


    Thank you,
    Pradeep.
    Last edited by kadiyala_p; 2007-06-27 at 15:10.

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: J2ME application doesnt open

    Hi Pradeep,

    Although there is no clear information regarding your application, note that Nokia 7210 is a CLDC 1.0/MIDP 1.0 device and E62 is CLDC 1.1/MIDP 2.0, so check your jad file and see what is there for your app.

    Are you sure you can install your app? May you post your jad here as well as inform the iDen phone(s) you are running properly?

    Br,
    Juarez Alvares Barbosa Junior - Brazil

  3. #3
    Registered User
    Join Date
    Jun 2007
    Posts
    28

    Re: J2ME application doesnt open

    Hi juarez,

    Thats a good news for me. Thank you so much. We actually dont support Midp 1.0 as of now. I appreciate your prompt response.

    Also FYI: I can install the application by assignt the midp version to 2.0.

    Thank you,
    Pradeep.

  4. #4
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: J2ME application doesnt open

    Hi Pradeep,

    You are welcome, glad to know you solved your problem

    Br,
    Juarez Alvares Barbosa Junior - Brazil

  5. #5
    Registered User
    Join Date
    Jun 2007
    Posts
    28

    Re: J2ME application doesnt open

    Hey juarez,

    Sorry man I did not ask for Nokia 7210. My previous question is for Nokia 7610 and it supports Midp 2.0. SO my problem here still exists. Also the JAD file looks some thing like this,

    MIDlet-1: App, fiw.png,com.XXXX
    MIDlet-Jar-Size: 162841
    MIDlet-Jar-URL: XYZ.jar
    MIDlet-Name: App
    MIDlet-Vendor: App
    MIDlet-Version: 2.1
    MicroEdition-Configuration: CLDC-1.0
    MicroEdition-Profile: MIDP-2.0
    NETWORK: mycingular.net
    PHONE_MODEL: CING
    SERVER_URL: https://xyz.com/

    Pradeep.

  6. #6
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: J2ME application doesnt open

    What APIs are you trying to access in your MIDlet? Check the supported APIs on 7610 in here http://forum.nokia.com/devices/7610

    Are you doing some memory intensive operations in the application?

    Hartti

  7. #7
    Registered User
    Join Date
    Jun 2007
    Posts
    28

    Re: J2ME application doesnt open

    The API that I think we are currently using is JSR 118 of MIDP 2.0 and we have a motorola.jar library which has only one class GenericCall.class. I see that Nokia has its own API.

    Is Nokia UI Api different from the JSR 118?.

    We actually are making https request to server and displaying response on the screen. The response is basically a custom response which is a simple string converted to bytes.

    Thank you,
    Pradeep.

  8. #8
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: J2ME application doesnt open

    The GenericCall class could have dependencies which cause the problem

    Nokia UI APi is different from MIDP 2. It was originally implemented because MIDP 1 implementation was not powerful enough. It is only available on Nokia phones for backward compatibility reasons.

    Hard to make any more detailed guesses without seeing the code.

    Hartti

  9. #9
    Registered User
    Join Date
    Jun 2007
    Posts
    28

    Re: J2ME application doesnt open

    Thanks Hartti. Thats good information I got from you. One final question for you.

    We have the same application with older version and the size of the obfuscated jar file is 155kb which actually worked on Nokia 7610. Now we made some changes to the code to add more features and after the obfuscation the file is 159kb. This new version does not work. Do you think its out of memory.

    Also do you know any debugging tools that would help me actually find the problems that I have with application on the nokia 7610 phone.

    Thank you,
    Pradeep.

  10. #10
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: J2ME application doesnt open

    If you can install the app, then it is small enough for the phone.
    Have you tried with the non-obfuscated version? Sometimes (not often, but still) the obfuscation can introduce problems.

    Unfortunately the On-Device-Debugging is possible only with S60 3rd Edition devices, so it does not help in here.
    Other than that I would suggest you to try the app on the 2nd Edition FP1 emulator, as you have a little better debugging possibilities while using the emulator.

    Hartti

  11. #11
    Registered User
    Join Date
    Jun 2007
    Posts
    3

    Re: J2ME application doesnt open

    Could be memory issue due to the size of the code itself... how much of the 159K is classes and how much is other resources?

    Also I recently ran into a bug where an ant-obfuscated build wouldn't run on a nokia, but a wireless toolkit build ran fine. What build process are you using?

    -joe

  12. #12
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: J2ME application doesnt open

    Hi joe,

    I think the problem might not be the process but the obfuscator you are using, there are some such as Proguard, mBooster, RetroGuard, DashO.

    Proguard is a good (and free) one, try it.

    Br,
    Juarez Alvares Barbosa Junior - Brazil

Similar Threads

  1. application error with 3gp file in J2ME
    By ruchig_iic in forum Mobile Java Media (Graphics & Sounds)
    Replies: 10
    Last Post: 2012-01-16, 21:40
  2. J2ME Application Network Settings
    By madankn in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2009-03-25, 07:37
  3. How can the WAP browser communicate to J2ME application?
    By hbfornies in forum Mobile Java General
    Replies: 20
    Last Post: 2007-03-02, 16:32
  4. why can't open contact in my application?
    By bily_pan in forum Symbian
    Replies: 2
    Last Post: 2006-08-31, 15:27
  5. Replies: 0
    Last Post: 2004-08-25, 11:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •