×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    problem with videoControl

    hi,
    I work with S60 3nd Edition platform, and I try to playing a video on my emulator.
    My player was correcty created with a 3GP file, but my VideoControl vc is every time equal to null, before and after
    vc = (VideoControl)p.getControl("VideoControl");
    My code:
    public Form doPlayMovie(String name_movie) {

    try {

    InputStream is = getClass().getResourceAsStream(name_movie);
    Player player = Manager.createPlayer(name_movie);
    player.realize();

    VideoControl vc = (VideoControl)p.getControl("VideoControl");
    if (vc != null) {

    Item it =(Item)vc.initDisplayMode(VideoControl.USE_GUI_PRIMITIVE,null);
    Form myForm = new Form(null, new Item[] {it});
    Display.getDisplay(midlet).setCurrent(form);
    }

    player.start();

    } catch (IOException ioe) {
    } catch (MediaException me) { }
    return myForm;
    }
    Any body know this problem?

  2. #2
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: problem with videoControl

    Does the code work on a real device?

    Hartti

  3. #3
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Re: problem with videoControl

    No Hartti, I work actually on an emulator.

    Do you know where could come from the problem?

    Thanks.

    Matt

  4. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Re: problem with videoControl

    Any think that the emulator is the origine of this problem?

    Matt

  5. #5
    Registered User
    Join Date
    Nov 2006
    Posts
    9

    Re: problem with videoControl

    how do you set up the emulator to play 3gps? i'm working on a video player too and can't manage to play 3pgs with either WTK oder Nokia S60 emulator

  6. #6
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Re: problem with videoControl

    Basically, I tried to do this, but my videoControl stay at null.
    So, I don't succeed to manage to play 3pgs with Nokia S60 emulator. But my player can load my video with the code of my first post. and I don't find to play an other extention file that 3GP, but I think that I need other library for do this.

    But, you can read a video on Nokia S60 emulator with other extention?
    Could you show me how you made, if you do that?

    Matt

Similar Threads

  1. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  2. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. wireless problem
    By sash_mca in forum Mobile Web Site Development
    Replies: 0
    Last Post: 2003-06-06, 11:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •