×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    S60 3rd FP1 troubles

    Hello,

    I am quite new in Symbian world, so first I want to apologize if my question(s) are trivial :D

    I have installed the following on my XP system, on disk C: (where the system is):

    - JRE 1.5.0_12 (couldn't find 1.5.0_6 as specified in ReleaseNotes for SDK 3rd FP1)
    -ActivePerl 5.6.1.631
    -S60 SDK 3rd FP1 for C++ (archive name: S60-SDK-200634-3[1].1-Cpp-f.1090b.zip)

    According with S60_CPP_SDK_3rd_FP1_InstallationGuide_1.0.pdf, the next step is to verify if the installation is correct and the SDK functional, and for this to compile and run into emulator the HelloWorldBasic example.

    I did the steps required:
    - bldmake bldfiles
    - abld build
    (all from Symbian\9.2\..\helloworldBasic\Group directory)

    The result of abld build is:

    make -r -f "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1_2\S60Ex\HelloWorldBasic\group\Export.make" EXPORT VERBOSE=-s
    Nothing to do


    When I start the emulator (epoc from Command line or from Start Menu), and go into Applications\Installed, the HelloWorldBAsic does not appear there, as the documentation says it should).

    Has anyone any idea why? Am I doing something wrong or am I missing something?

    Thank you!

    Adriana.
    Last edited by Adriana_P; 2007-07-11 at 10:31.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: S60 3rd FP1 troubles

    Commands
    abld build winscw udeb (for the emulator)
    abld build gcce urel (for target device)
    may do a bit more.
    However you cannot build for the emulator with a bare SDK, and it might also apply to building for the target device.

  3. #3
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    Re: S60 3rd FP1 troubles

    Thank you.

    Using abld build winscw udeb I get now some compilings but also an error, and it hang at the end at "convert files...".

    The error is: "ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation"

    I guess this is related to what you said:

    However you cannot build for the emulator with a bare SDK(...)

    All these means that I have to install also in IDE in order to have HelloWorldBasic running on the emulator?

    Adriana.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: S60 3rd FP1 troubles

    Yes, you need an IDE (for example Carbide http://www.forum.nokia.com/main/reso...cpp/index.html)

  5. #5
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    Re: S60 3rd FP1 troubles

    OK, thank you.

    I cannot find again where I red about what IDE are supported by SDK 3rd Ed.

    For SDK 2nd Ed I could use Visual Studio 6 as IDE.

    Is this supported also by SDK 3rd Ed? To what reffers that "vs6" project platform for abld command?

  6. #6
    Regular Contributor
    Join Date
    May 2007
    Posts
    463

    Re: S60 3rd FP1 troubles

    Well, the fact that it stopped at "converting files" isn't really to do with lacking an IDE (though you do need one even to compile for the emulator on the command line, SDKs don't ship with a wins compiler.) The problem there is that mifconv won't run if the emulator is running, for reasons I can't really fathom, it uses the epoc tree for its temp files, and doubtless can't write them while that tree is locked.
    Get Resolvr - The Zeroconf framework for Symbian OS free today. Make your IP networking applications fun and easy to use. http://www.novelinteractions.com/resolvr/
    Proud to be the only autorickshaw owner in Cambridge - http://blog.novelinteractions.com/images/tuktuk.jpg

  7. #7
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    Re: S60 3rd FP1 troubles

    Quote Originally Posted by cdavies-nokia
    Well, the fact that it stopped at "converting files" isn't really to do with lacking an IDE (though you do need one even to compile for the emulator on the command line, SDKs don't ship with a wins compiler.) The problem there is that mifconv won't run if the emulator is running, for reasons I can't really fathom, it uses the epoc tree for its temp files, and doubtless can't write them while that tree is locked.
    I can confirm this, I tried again to build after I closed the emulator, and it didn't hang anymore.

  8. #8
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    Re: S60 3rd FP1 troubles

    I installed Visual Studio.NET 2003, then Carbide.vs 2.01, and still the same problem - error at building the udeb version for emulator, and ofcourse no HelloWorldBAsic app in Emulator :(

    Any idea what is still missing?

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: S60 3rd FP1 troubles

    Then try compiling from the IDE. I do not know Carbide.vs in particular, but there should be some kind of Import command, where you can select the bld.inf or the .mmp file from the group folder.

  10. #10
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Smile Re: S60 3rd FP1 troubles

    Quote Originally Posted by wizard_hu_
    Then try compiling from the IDE. I do not know Carbide.vs in particular, but there should be some kind of Import command, where you can select the bld.inf or the .mmp file from the group folder.
    Yes. You can import bld.inf or .mmp file from
    File-> Import Symbian Project
    Then select "Symbian 9" from the drope down list.

    Once you have successfully imported your project, you can then Clean - Rebuild your project.

    All the best.
    Kiran.

  11. #11
    Registered User
    Join Date
    Jul 2007
    Location
    Germany
    Posts
    48

    Re: S60 3rd FP1 troubles

    I did this - Import in VS.NET 2003 with Carbide.vs installed, Clean and Rebuild Solution, and IT WORKS!!! Finally I can see HelloWorldBasic in Emulator and also it works.

    I am moving now to porting my project from 2nd to 3rd edition - this is actually the big fight :D

    Thanks guys!

    Have a magical day,
    Adriana.
    Last edited by Adriana_P; 2007-07-12 at 09:29.

Similar Threads

  1. speech recognition in s60 3rd edition
    By fatema27 in forum Symbian
    Replies: 10
    Last Post: 2008-08-14, 06:06
  2. Replies: 5
    Last Post: 2007-06-27, 13:35
  3. Replies: 0
    Last Post: 2007-03-28, 08:59
  4. Problem with registering S60 3rd Edition FP1 emulator?
    By mayur_24 in forum Tools and SDK Feedback (Closed)
    Replies: 2
    Last Post: 2006-12-12, 07:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×